Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-22803

'JellyTagException: <st:include> For input string: ""' on job view

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      Problem ocurring on Jenkins 1.557: on job view of a given project, an embedded error page is shown with stacktrace attached. It appeared after our last build.

        Attachments

        1. config.xml
          9 kB
        2. jenkinsbug.png
          jenkinsbug.png
          114 kB
        3. jenkinsbug.txt
          14 kB

          Issue Links

            Activity

            danielbeck Daniel Beck added a comment -

            This is caused by Parameterized Trigger plugin. Please provide the version of the plugin you're using. Also, is the user viewing this job page allowed to access the jobs triggered by the selected job? Does it work if a user allowed to access those jobs views this job's page?

            ikedam ikedam added a comment -

            Parameterized trigger plugin just calls Job#getLastSuccessfulBuild.
            It's not reasonable to expect java.lang.NumberFormatException is thrown from Job#getLastSuccessfulBuild, and I think this is a problem that should be fixed Jenkins core.

            Job#getLastSuccessfulBuild looks switched to use PeepholePermalink since jenkins-1.507.
            https://github.com/jenkinsci/jenkins/commit/88feabb4296d6483bdb5c85fed489e5014161ca5

            I'm not sure what causes lastSuccessfulBuild, which is a symlink, points not null but an empty file name.

            Please report details how to reproduce this problem.

            ikedam ikedam added a comment -

            There seem issues with the same problem. (linked)
            Looks a problems on Windows, and maybe with Maven Projects.

            danielbeck Daniel Beck added a comment -

            João Enomoto:

            Is this on an OS that does not have symbolic link support?

            What kind of file/folder is 'lastSuccessfulBuild' in the directory JENKINS_HOME/jobs/(jobname)/builds ? If it's a text file, what is its contents?

            jfaenomoto João Enomoto added a comment -

            Sorry for being a bit late.

            Our Jenkins server is a Windows Server 2008 R2. Not quite sure if is there symbolic link support for it, already heard about it somehow but not completely sure. 'lastSuccessfulBuild' is a text file whose content is a integer number, probably pointing to an build's id.


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              jfaenomoto João Enomoto
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: