Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-22847

Configuration of Jenkins slave(s) is lost after restart of Jenkins master

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Labels:
      None
    • Environment:
    • Similar Issues:

      Description

      hi

      we are starting our slave via "launch slave agents on unix machines via SSH"
      the slave is working properly but whenever Jenkins master is restarted, the slave is gone and needs to be created again.

      is this epected bahavior?

      thanks

        Attachments

          Issue Links

            Activity

            markewaite Mark Waite added a comment -

            That is not the expected behavior. Since you said that the slave is configured be be launched from the master, that means it is not a "swarm" slave, so it should automatically attempt to restart after reboot, and should remain in the list even if the restart fails.

            I suspect there is a problem in your Jenkins configuration, rather than a problem in Jenkins. If Jenkins were behaving like that in general, I would expect many users to complain. You may want to investigate if something is reverting your Jenkins configuration when the master restarts, or if something is somehow removing the slave definition files on the master server.

            You might also consider switching from 1.549 to the long term support release (currently 1.554.1). Unless you need to be "on the cutting edge", the LTS version tends to be more stable than the development versions

            jaredhodge Jared Hodge added a comment - - edited

            I am seeing this same behavior using build 1.567. Oddly enough I just rebooted and one of the two slaves was still there and the other had disappeared (on previous reboots both disappeared). I am also using ssh to Linux slave nodes.

            It also forgot settings for the main Jenkins server when I did an update (through yum), which I think is not the expected behavior either since it preserved all my jobs.

            rickybobpat Rick Patterson added a comment -

            This sounds similar to https://issues.jenkins-ci.org/browse/JENKINS-22525. That one is on Windows, and seems due to the use of IBM Java.

            The following also seems related, is on Linux, and also uses IBM Java: https://issues.jenkins-ci.org/browse/JENKINS-22006.

            There is a Jenkins item opened about problem with IBM J9 Java support: https://issues.jenkins-ci.org/browse/JENKINS-23176.

            Could you indicate what your Java version is? if these items noted above seem to be the problem, this could be closed as a duplicate of one of the above.

            ediren edwin renner added a comment -

            our java version is also based on IBM JVM.

            java version "1.7.0"
            Java(TM) SE Runtime Environment (build pxa6470sr4fp2-20130426_01(SR4 FP2))
            IBM J9 VM (build 2.6, JRE 1.7.0 Linux amd64-64 Compressed References 20130422_14 
            
            ediren edwin renner added a comment -

            resolved this issue as it is handled in JENKINS-22525 already.


              People

              Assignee:
              kohsuke Kohsuke Kawaguchi
              Reporter:
              ediren edwin renner
              Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: