Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-23115

IRC Plugin throwing NPE

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: ircbot-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.554.1
    • Similar Issues:

      Description

      Getting that whenever I try to setup the IRC Bot. Tried different IRC servers + ports but nothing helps. Using 2.25

      INFO: Connecting to irc.eu.esper.net:5555 as Test76895 using charset UTF-8
      May 20, 2014 4:15:01 PM hudson.plugins.ircbot.v2.IRCConnection connect
      WARNING: Error connecting to irc
      java.lang.NullPointerException
      	at org.pircbotx.PircBotX.shutdown(PircBotX.java:2853)
      	at org.pircbotx.PircBotX.connect(PircBotX.java:452)
      	at hudson.plugins.ircbot.v2.IRCConnection.connect(IRCConnection.java:129)
      	at hudson.plugins.ircbot.v2.IRCConnectionProvider.createConnection(IRCConnectionProvider.java:37)
      	at hudson.plugins.im.IMConnectionProvider.create(IMConnectionProvider.java:65)
      	at hudson.plugins.im.IMConnectionProvider.access$600(IMConnectionProvider.java:22)
      	at hudson.plugins.im.IMConnectionProvider$ConnectorRunnable.run(IMConnectionProvider.java:183)
      	at java.lang.Thread.run(Thread.java:744)
      May 20, 2014 4:15:01 PM hudson.plugins.im.IMConnectionProvider$ConnectorRunnable run
      INFO: Reconnect failed. Next connection attempt in 1 minutes
      

        Attachments

          Activity

          kutzi kutzi added a comment -

          Anything else in the logs or on stdout?
          There stacktrace suggests that there is an error on connecting to the server (nick already in use or some other error)

          recon88 Ingo Guther added a comment -

          That's all I get in the logfile.
          Nickname is not in use. Tried the same server + port + nick on my local machine with an IRC client and it works fine.

          recon88 Ingo Guther added a comment -

          I just contacted my host and got that as response:

          "We don't block those ports, more likely you're hitting an issue where the connection framework is attempting to bind to 0.0.0.0 when making the client socket connection, which we do not allow."

          Could that be the issue? Is there a workaround?

          recon88 Ingo Guther added a comment -

          Just went through the PircBotX source and found the method getLocalAddress() which may return 0.0.0.0.
          So I guess my host was right and the framework tries to bind 0.0.0.0.

          kutzi kutzi added a comment -

          Good to know.

          Do you want to report an issue against the PircBotX project?

          recon88 Ingo Guther added a comment -

          I need that fix as soon as possible so no. I don't think they will implement it right away.
          Since the source is available, I'm just going to fix it by myself.

          kutzi kutzi added a comment -

          That's fine for me, but in the spirit of open source you should IMO at least let them know that somnething is broken (by creating a new issue) and - if you already have it - attaching your patch.

          kutzi kutzi added a comment -

          Closing because: Not a bug on Jenkins plugin side


            People

            Assignee:
            kutzi kutzi
            Reporter:
            recon88 Ingo Guther
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: