Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-23172

Config file provided via the REST api is missing "owner" tags

    XMLWordPrintable

Details

    • Bug
    • Resolution: Unresolved
    • Minor
    • core
    • None

    Description

      I was able to create a new view within an existing nested view, as described by Patric Boström in the comments for this issue:

      https://issues.jenkins-ci.org/browse/JENKINS-8927

      The new view is inserted correctly and works fine. However, this seems to have broken other nested views as they are no longer found (HTTP error 404). I have attached the error message written in jenkins the log file.

      It seems that when I get the config.xml via the REST api, it is missing the "owner" nodes. This can be seen by comparing get_config.xml (received via the REST api) and partial_config.xml (an extract from the jenkins config.xml file).

      As a work around, it is possible to insert them before updating the view.

      Attachments

        1. get_config.xml
          19 kB
          Leanne Matuszyk
        2. jenkins_error.txt
          11 kB
          Leanne Matuszyk
        3. partial_config.xml
          26 kB
          Leanne Matuszyk

        Issue Links

          Activity

            People

              Unassigned Unassigned
              leanne_matuszyk Leanne Matuszyk
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated: