Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2352

Option to keep artifacts from last stable (not just successful) build

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: other
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      For a server I help maintain, we like to publish the results of the last build
      that passed all its tests, so we point clients to

      http://deadlock.netbeans.org/hudson/job/nbms-and-javadoc/lastStableBuild/artifact/nbbuild/nbms/updates.xml.gz

      The project configuration GUI has an option

      "Discard all but the last successful artifact to save disk space"

      We would like to save disk space, but this option is useless for us: if a build
      completes with some test failures, Hudson would delete the artifacts from the
      stable build preceding it, breaking the link!

      What we would like is a similar option to keep just artifacts from the last
      stable build. Alternately, modify the behavior of the existing option to always
      keep artifacts from the last stable build, as well as those from the last
      unstable build if that is newer (since you might well want both to be available).

        Attachments

          Issue Links

            Activity

            jglick Jesse Glick added a comment -

            Seems I can file the same bug within a couple of weeks with no memory of doing so...

                • This issue has been marked as a duplicate of 2417 ***

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              jglick Jesse Glick
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: