Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-23616

Jenkins RPM should have a dependency with x11-devel (required to properly render workspace)

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: core
    • Labels:
    • Environment:
      Linux, RPM based
    • Similar Issues:

      Description

      It appears as if without x11-devel libraries installed, a NPE occurs when trying to render the workspace. Therefore, it'll ease people's life if x11-devel will be a dependency of the Jenkins RPM.

        Attachments

          Activity

          danielbeck Daniel Beck added a comment -

          Could you provide the exception stack trace?

          oleg_nenashev Oleg Nenashev added a comment -

          Cannot reproduce on RHEL6.4 w/o x11-devel (1.509.4).
          Please provide info about your system and the Jenkins core version

          ykaul Yaniv Kaul added a comment -

          I can't reproduce it now. Strange. I'll close this and if I'll see an execption again I'll re-open.

          danielbeck Daniel Beck added a comment -

          Maybe this was about the fonts package instead, as reported in JENKINS-25261?


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            ykaul Yaniv Kaul
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: