Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2394

Timeout problem for Maven2 project build

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: Windows XP
    • Similar Issues:

      Description

      It sometimes fails in running the Maven2 project build, which often goes well by
      trying again. We get the following error messages.

      [Beckmann] $ C:\Bin\Java\1.5.0_15/bin/java -Dmaven.test.skip=true -Xmx1024m -cp
      C:\Bin\Tomcat\6.0-v2\webapps\hudson\WEB-INF\lib\maven-agent-1.252.jar;C:\Bin\Maven\2.0.9\boot\classworlds-1.1.jar
      hudson.maven.agent.Main C:\Bin\Maven\2.0.9
      C:\Bin\Tomcat\6.0-v2\webapps\hudson\WEB-INF\lib\remoting-1.252.jar
      C:\Bin\Tomcat\6.0-v2\webapps\hudson\WEB-INF\lib\maven-interceptor-1.252.jar 4004
      ERROR: Failed to parse POMs
      java.net.SocketTimeoutException: Accept timed out
      at java.net.PlainSocketImpl.socketAccept(Native Method)
      at java.net.PlainSocketImpl.accept(PlainSocketImpl.java:384)
      at java.net.ServerSocket.implAccept(ServerSocket.java:453)
      at java.net.ServerSocket.accept(ServerSocket.java:421)
      at
      hudson.maven.MavenProcessFactory$SocketHandler$AcceptorImpl.accept(MavenProcessFactory.java:142)
      at hudson.maven.MavenProcessFactory.newProcess(MavenProcessFactory.java:175)
      at hudson.maven.ProcessCache.get(ProcessCache.java:170)
      at
      hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:329)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:240)
      at hudson.model.Run.run(Run.java:793)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:205)
      at hudson.model.ResourceController.execute(ResourceController.java:70)
      at hudson.model.Executor.run(Executor.java:88)
      finished: FAILURE

        Attachments

          Issue Links

            Activity

            kohsuke Kohsuke Kawaguchi added a comment -
                • Issue 2441 has been marked as a duplicate of this issue. ***
            kohsuke Kohsuke Kawaguchi added a comment -
                • Issue 1835 has been marked as a duplicate of this issue. ***
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : kohsuke
            Path:
            trunk/hudson/main/core/src/main/java/hudson/Proc.java
            trunk/hudson/main/core/src/main/java/hudson/maven/MavenProcessFactory.java
            trunk/www/changelog.html
            http://fisheye4.cenqua.com/changelog/hudson/?cs=15501
            Log:
            [FIXED JENKINS-2394] Improved error handling when Maven fails to start correctly in the m2 project type.


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              u_simplex u_simplex
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: