Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2428

NPE in CVSChangeSet when CVS has not been set up

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: cvs-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Clicking on the Authors link causes a NullPointerException in the CVS library. I
      have not configured CVS, as I use the Perforce SCM.
      As far as I can tell, there is no way to remove or disable the CVS setting in
      the hudson preferences.

      java.lang.NullPointerException
      at
      hudson.scm.CVSChangeLogSet$CVSChangeLog.canBeMergedWith(CVSChangeLogSet.java:116)
      at hudson.scm.CVSChangeLogSet.parse(CVSChangeLogSet.java:86)
      at hudson.scm.CVSChangeLogParser.parse(CVSChangeLogParser.java:15)
      at hudson.scm.CVSChangeLogParser.parse(CVSChangeLogParser.java:13)
      at hudson.model.AbstractBuild.calcChangeSet(AbstractBuild.java:367)
      at hudson.model.AbstractBuild.getChangeSet(AbstractBuild.java:349)
      at hudson.model.View$People.(View.java:207)
      at hudson.model.View.getPeople(View.java:192)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.kohsuke.stapler.Function$InstanceFunction.invoke(Function.java:103)
      at org.kohsuke.stapler.MetaClass$4.doDispatch(MetaClass.java:140)
      at org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
      at org.kohsuke.stapler.Stapler.invoke(Stapler.java:409)
      at org.kohsuke.stapler.Stapler.invoke(Stapler.java:352)
      at org.kohsuke.stapler.Stapler.service(Stapler.java:112)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:45)
      at winstone.ServletConfiguration.execute(ServletConfiguration.java:249)
      at winstone.RequestDispatcher.forward(RequestDispatcher.java:335)
      at winstone.RequestDispatcher.doFilter(RequestDispatcher.java:378)
      at hudson.util.PluginServletFilter$1.doFilter(PluginServletFilter.java:61)
      at hudson.util.PluginServletFilter.doFilter(PluginServletFilter.java:53)
      at winstone.FilterConfiguration.execute(FilterConfiguration.java:195)
      at winstone.RequestDispatcher.doFilter(RequestDispatcher.java:368)
      at hudson.security.HudsonFilter.doFilter(HudsonFilter.java:88)
      at winstone.FilterConfiguration.execute(FilterConfiguration.java:195)
      at winstone.RequestDispatcher.doFilter(RequestDispatcher.java:368)
      at winstone.RequestDispatcher.forward(RequestDispatcher.java:333)
      at winstone.RequestHandlerThread.processRequest(RequestHandlerThread.java:244)
      at winstone.RequestHandlerThread.run(RequestHandlerThread.java:150)
      at java.lang.Thread.run(Unknown Source)

        Attachments

          Activity

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : kohsuke
          Path:
          trunk/hudson/main/core/src/main/java/hudson/scm/CVSChangeLogSet.java
          trunk/www/changelog.html
          http://fisheye4.cenqua.com/changelog/hudson/?cs=12531
          Log:
          [FIXED JENKINS-2428]
          This is caused by incomplete changelog.xml.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            folkstone42 folkstone42
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: