Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-24725

Jenkins fails to start

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      Solaris 11, Java 7, Jenkins 1.580
    • Similar Issues:

      Description

      Jenkins fails to start..

      It seems to start alright, but no response from the http service. Seems to be an issue with loading JSP?

      [ Sep 16 11:38:22 Executing start method ("java -version:1.7* $JAVA_OPTS -jar $JENKINS_HOME/jenkins.war --prefix=/jenkins"). ]
      Running from: /apps/jenkins/webapp/jenkins.war
      webroot: EnvVars.masterEnvVars.get("JENKINS_HOME")
      Sep 16, 2014 11:38:23 AM winstone.Logger logInternal
      INFO: Beginning extraction from war file
      Sep 16, 2014 11:38:23 AM org.eclipse.jetty.util.log.JavaUtilLog info
      INFO: jetty-8.y.z-SNAPSHOT
      Sep 16, 2014 11:38:26 AM org.eclipse.jetty.util.log.JavaUtilLog info
      INFO: NO JSP Support for /jenkins, did not find org.apache.jasper.servlet.JspServlet
      Jenkins home directory: /apps/jenkins/webapp found at: EnvVars.masterEnvVars.get("JENKINS_HOME")
      Sep 16, 2014 11:38:27 AM org.eclipse.jetty.util.log.JavaUtilLog info
      INFO: Started SelectChannelConnector@0.0.0.0:8080
      Sep 16, 2014 11:38:27 AM winstone.Logger logInternal
      INFO: Winstone Servlet Engine v2.0 running: controlPort=disabled
      Sep 16, 2014 11:38:27 AM jenkins.InitReactorRunner$1 onAttained
      INFO: Started initialization
      Sep 16, 2014 11:38:27 AM jenkins.InitReactorRunner$1 onAttained

      The service is managed as a service on Solaris 11:

      <?xml version='1.0'?>
      <!DOCTYPE service_bundle SYSTEM '/usr/share/lib/xml/dtd/service_bundle.dtd.1'>
      <service_bundle type='manifest' name='export'>
      <service name='application/jenkins' type='service' version='0'>
      <create_default_instance enabled='true'/>
      <single_instance/>
      <dependency name='multi-user-server' grouping='require_all' restart_on='none' type='service'>
      <service_fmri value='svc:/milestone/multi-user-server'/>
      </dependency>
      <method_context project=':default' resource_pool=':default' working_directory=':default'>
      <method_credential group='staff' limit_privileges=':default' supp_groups=':default' user='jenkins' privileges='basic,net_privaddr'/>
      <method_environment>
      <envvar name='PATH' value='/usr/gnu/bin:/usr/bin:/usr/sbin'/>
      <envvar name='JAVA_OPTS' value='-d64 -server -Djava.awt.headless=true -XX:+UnlockExperimentalVMOptions -XX:+UseG1GC -XX:+UseNUMA -XX:MaxPermSize=1024m -Xmx8192m'/>
      <envvar name='JAVA_HOME' value='/usr/jdk/latest'/>
      <envvar name='HOME' value='/apps/jenkins/home'/>
      <envvar name='JENKINS_HOME' value='/apps/jenkins/webapp'/>
      </method_environment>
      </method_context>
      <exec_method name='start' type='method' exec='java -version:1.7* $JAVA_OPTS -jar $JENKINS_HOME/jenkins.war --prefix=/jenkins' timeout_seconds='0'>
      <method_context/>
      </exec_method>
      <exec_method name='stop' type='method' exec=':kill -TERM' timeout_seconds='30'>
      <method_context/>
      </exec_method>
      <property_group name='startd' type='framework'>
      <propval name='duration' type='astring' value='child'/>
      </property_group>
      <stability value='Unstable'/>
      <template>
      <common_name>
      <loctext xml:lang='C'>Jenkins Continuous Build Server</loctext>
      </common_name>
      <documentation>
      <doc_link name='jenkins-ci.org' uri='http://jenkins-ci.org'/>
      </documentation>
      </template>
      </service>
      </service_bundle>

        Attachments

          Issue Links

            Activity

            plheide Pete E added a comment -

            The issue is present when trying to upgrade to any version from version 1.532.1.

            danielbeck Daniel Beck added a comment -

            Duplicates JENKINS-24357.


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              plheide Pete E
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: