Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-24906

Debian package LTS v1.565.2 has corrupt jenkins.war

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Won't Fix
    • Component/s: packaging
    • Environment:
    • Similar Issues:

      Description

      Here's the checksum difference. From the Jenkins website.

      1. md5sum jenkins.war
        e53d793e42d1686ab103960dbd17979a jenkins.war

      From the package.

      1. grep 'jenkins.war' /var/lib/dpkg/info/jenkins*.md5sums
        /var/lib/dpkg/info/jenkins-common.md5sums:2cc48f1f0341b8c54659e0af73cc3115 usr/share/jenkins/jenkins.war

      I troubleshooted this for a few hours and thought there was something wrong with my Jenkins instance. After I downloaded the LTS from the website and moved it into /usr/share/jenkins/jenkins.war and restarted the service; my Jenkins instance started behaving correctly again.

        Attachments

          Activity

          sag47 Sam Gleske created issue -
          danielbeck Daniel Beck made changes -
          Field Original Value New Value
          Resolution Not A Defect [ 7 ]
          Status Open [ 1 ] Resolved [ 5 ]
          sag47 Sam Gleske added a comment -

          I believe this is an incorrect response to this issue. I installed the Debian package from http://pkg.jenkins-ci.org/debian-stable/

          In no way is the debian project involved with Jenkins packaging the corrupt war. I implore you to re-open this issue and investigate.

          It works when I download the jenkins.war from http://mirrors.jenkins-ci.org/war-stable/latest/jenkins.war

          It does not work when using jenkins.war provided by the Jenkins built Debian package.

          sag47 Sam Gleske made changes -
          Resolution Not A Defect [ 7 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          danielbeck Daniel Beck made changes -
          Status Reopened [ 4 ] Open [ 1 ]
          danielbeck Daniel Beck added a comment -

          Right, sorry about that.

          Could you explain why the checksum of jenkins-common, which appears to be (part of) the Debian packaged Jenkins, is relevant?

          sag47 Sam Gleske added a comment -

          The checksum as part of debian packaged jenkins is relevant because the checksum matches my installed war. So that means my war didn't corrupt after the fact. The checksum from the war is different than what is [provided as a direct download][1]. When I overwrite /usr/share/jenkins/jenkins.war with the [direct download war][1] and restart jenkins /etc/init.d/jenkins restart... our instance behaves normally once again.

          I don't know the build/packaging process so it's entirely possible that the jenkins package is different in how it builds so the checksum will always be different than direct download jenkins. However, I opened this report because our instance of jenkins is broken when using the package version of jenkins.war and not broken when using the direct download version.

          [1]: http://mirrors.jenkins-ci.org/war-stable/latest/jenkins.war

          oldelvet Richard Mortimer added a comment -

          I don't see any corruption in the Debian package. The md5sums are correct compared against downloaded war files and the information contained within the .deb. Are you sure that you have the right version installed?

          $ mkdir /tmp/jenkins
          $ cd /tmp/jenkins
          $ wget http://pkg.jenkins-ci.org/debian-stable/binary/jenkins_1.565.2_all.deb
          $ mkdir jenkins_1.565.2_all
          $ dpkg-deb -R jenkins_1.565.2_all.deb jenkins_1.565.2_all
          $ wget http://mirrors.jenkins-ci.org/war-stable/latest/jenkins.war
          $ wget -O jenkins-1.565.2.war http://mirrors.jenkins-ci.org/war-stable/1.565.2/jenkins.war
          
          $ md5sum jenkins.war jenkins-1.565.2.war jenkins_1.565.2_all/usr/share/jenkins/jenkins.war
          e53d793e42d1686ab103960dbd17979a  jenkins.war
          e53d793e42d1686ab103960dbd17979a  jenkins-1.565.2.war
          e53d793e42d1686ab103960dbd17979a  jenkins_1.565.2_all/usr/share/jenkins/jenkins.war
          $ grep jenkins.war jenkins_1.565.2_all/DEBIAN/md5sums
          e53d793e42d1686ab103960dbd17979a  usr/share/jenkins/jenkins.war
          
          oldelvet Richard Mortimer added a comment -

          The contents of the changelog should be available for viewing via

          zless /usr/share/doc/jenkins/changelog.gz
          
          oldelvet Richard Mortimer added a comment -

          I just spotted Daniel's comment about jenkins-common. The fact that /var/lib/dpkg/info/jenkins-common.md5sums exists suggests that it is the Debian distribution package that is installed and not the upstream packaged version.

          This is confirmed by checking the Debian distribution .deb file

          $ wget http://ftp.uk.debian.org/debian/pool/main/j/jenkins/jenkins-common_1.565.2-2_all.deb
          s$ mkdir jenkins-common_1.565.2-2_all
          $ dpkg-deb -R jenkins-common_1.565.2-2_all.deb jenkins-common_1.565.2-2_all
          $ md5sum jenkins-common_1.565.2-2_all/usr/share/jenkins/jenkins.war
          2cc48f1f0341b8c54659e0af73cc3115  jenkins-common_1.565.2-2_all/usr/share/jenkins/jenkins.war
          $ grep jenkins.war jenkins-common_1.565.2-2_all/DEBIAN/control  md5sums
          $ grep jenkins.war jenkins-common_1.565.2-2_all/DEBIAN/md5sums
          2cc48f1f0341b8c54659e0af73cc3115  usr/share/jenkins/jenkins.war
          

          Conclusion this is a Debian project issue and not a Jenkins upstream issue.

          teilo James Nord made changes -
          Component/s packaging [ 20120 ]
          Component/s debian-package-builder-plugin [ 17529 ]
          teilo James Nord added a comment -

          as per last comment this is a bug in the Debain projects repackage Jenkins and not in our Debian package

          teilo James Nord made changes -
          Resolution Won't Fix [ 2 ]
          Status Open [ 1 ] Closed [ 6 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 158544 ] JNJira + In-Review [ 208085 ]

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            sag47 Sam Gleske
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: