Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-24946

JUnit Tests Results fail to archive in V1.582

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Critical
    • Resolution: Cannot Reproduce
    • junit-plugin
    • None
    • Jenkins 1.582 running as a service on Windows7, building on Slaves also running as services on Windows7 machines.

      JUnit Plugin 1.1

    Description

      Stack trace has certain elements replaced with <generic terms>

      ERROR: Failed to archive test reports
      java.io.IOException: remote file operation failed: c:\jenkins_slave\workspace\<Job Name> at hudson.remoting.Channel@3c0156a0:<Machine Name>
      at hudson.FilePath.act(FilePath.java:914)
      at hudson.FilePath.act(FilePath.java:896)
      at hudson.tasks.junit.JUnitParser.parse(JUnitParser.java:87)
      at hudson.tasks.junit.JUnitResultArchiver.parse(JUnitResultArchiver.java:129)
      at hudson.tasks.junit.JUnitResultArchiver.perform(JUnitResultArchiver.java:141)
      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:770)
      at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:734)
      at hudson.model.Build$BuildExecution.post2(Build.java:183)
      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:683)
      at hudson.model.Run.execute(Run.java:1770)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:89)
      at hudson.model.Executor.run(Executor.java:240)

      Reverting to pre 1.577 version (ie before JUnit was split out to a plugin) fault does not occur

      Attachments

        Issue Links

          Activity

            danielbeck Daniel Beck added a comment -

            Alright, resolving this as Cannot Reproduce as upgrading from 1.1 to 1.2 seems like a viable solution. 1.3 has the incompatibility problem but that's inherent in the current dependency declaration / LTS versioning, so please look the other way

            (Also, weekly releases are only considered supported for a week, which means if you're still running 1.594 or 1.595, you're on your own )

            danielbeck Daniel Beck added a comment - Alright, resolving this as Cannot Reproduce as upgrading from 1.1 to 1.2 seems like a viable solution. 1.3 has the incompatibility problem but that's inherent in the current dependency declaration / LTS versioning, so please look the other way (Also, weekly releases are only considered supported for a week, which means if you're still running 1.594 or 1.595, you're on your own )

            Encountered this problem on 1.583 when installing v1.3 of jUnit. Tried v1.4, same result. Manually resinstalled v1.2 works. The problem is still in there somewhere ...
            Archiving artifacts
            Recording test results
            ERROR: Publisher hudson.tasks.junit.JUnitResultArchiver aborted due to exception
            java.lang.NoClassDefFoundError: hudson/tasks/junit/JUnitParser$ParseResultCallable
            at hudson.tasks.junit.JUnitParser.parseResult(JUnitParser.java:90)
            at hudson.tasks.junit.JUnitResultArchiver.parse(JUnitResultArchiver.java:120)
            at hudson.tasks.junit.JUnitResultArchiver.perform(JUnitResultArchiver.java:137)
            at hudson.tasks.BuildStepCompatibilityLayer.perform(BuildStepCompatibilityLayer.java:74)
            at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
            at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:770)
            at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:734)
            at hudson.model.Build$BuildExecution.post2(Build.java:183)
            at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:683)
            at hudson.model.Run.execute(Run.java:1770)
            at hudson.matrix.MatrixRun.run(MatrixRun.java:146)
            at hudson.model.ResourceController.execute(ResourceController.java:89)
            at hudson.model.Executor.run(Executor.java:240)

            kengra Kent Granström added a comment - Encountered this problem on 1.583 when installing v1.3 of jUnit. Tried v1.4, same result. Manually resinstalled v1.2 works. The problem is still in there somewhere ... Archiving artifacts Recording test results ERROR: Publisher hudson.tasks.junit.JUnitResultArchiver aborted due to exception java.lang.NoClassDefFoundError: hudson/tasks/junit/JUnitParser$ParseResultCallable at hudson.tasks.junit.JUnitParser.parseResult(JUnitParser.java:90) at hudson.tasks.junit.JUnitResultArchiver.parse(JUnitResultArchiver.java:120) at hudson.tasks.junit.JUnitResultArchiver.perform(JUnitResultArchiver.java:137) at hudson.tasks.BuildStepCompatibilityLayer.perform(BuildStepCompatibilityLayer.java:74) at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:770) at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:734) at hudson.model.Build$BuildExecution.post2(Build.java:183) at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:683) at hudson.model.Run.execute(Run.java:1770) at hudson.matrix.MatrixRun.run(MatrixRun.java:146) at hudson.model.ResourceController.execute(ResourceController.java:89) at hudson.model.Executor.run(Executor.java:240)
            weakcamel Waldek M added a comment -

            You may want to upgrade core version.
            I was on 1.586 and upgrade finally solved it for me, as advised by Daniel Beck above.

            weakcamel Waldek M added a comment - You may want to upgrade core version. I was on 1.586 and upgrade finally solved it for me, as advised by Daniel Beck above.

            Silly me
            RTFM before writing...
            Thanx Waldek M

            kengra Kent Granström added a comment - Silly me RTFM before writing... Thanx Waldek M

            Reverting issue to its previous state since it is explained in the comments why it doesn't work with 1.583.

            The release-notes for the plugin however should perhaps state the incompatibility even though it is compatible with later versions of Jenkins.

            kengra Kent Granström added a comment - Reverting issue to its previous state since it is explained in the comments why it doesn't work with 1.583. The release-notes for the plugin however should perhaps state the incompatibility even though it is compatible with later versions of Jenkins.

            People

              Unassigned Unassigned
              d_shepherd Duncan Shepherd
              Votes:
              3 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: