Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-24955

Quiet period doesn't work

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: core
    • Labels:
    • Environment:
      Windows 7 or windows server 2012R2
      Jenkins 1.582, Jenkins 1.565.3, Jenkins 1.565.1
    • Similar Issues:

      Description

      If I configure a quiet period in a freestyle project or in configure system, it doesn't work, the build is started immediately.

        Attachments

          Activity

          danielbeck Daniel Beck added a comment - - edited

          Are you sure it's not just the 'Build Now' button overriding it by supplying the ?delay=0sec argument? What happens when you remove that, or trigger the build from another job, SCM, or using the timer?

          Since you tagged this regression: In which release did it work differently?

          pooja pooja shah added a comment - - edited

          Hi Daniel,
          Jenkins version: 1.629

          yes root cause is: default param "build?delay=0sec" in job's build with parameters option, it overrides the 'quiet period' setting
          any idea how can I make it work when I'm calling this job in my build step?
          refer screenshot, test_test is the job which has quiet period set but it doesn't work because of the obvious reason

          pooja pooja shah added a comment -

          seeing similar issue : https://issues.jenkins-ci.org/browse/JENKINS-6660
          any work around?


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            mcantin Mathieu Cantin
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: