Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-25532

java.util.zip.ZipException: invalid literal/length code in JacocoPublisher

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Critical
    • Resolution: Cannot Reproduce
    • jacoco-plugin
    • Jenkins ver. 1.569

    Description

      My Jacoco code coverage job started failing with this exception:

      ERROR: Publisher hudson.plugins.jacoco.JacocoPublisher aborted due to exception
      java.util.zip.ZipException: invalid literal/length code
      at java.util.zip.InflaterInputStream.read(InflaterInputStream.java:164)
      at java.util.zip.ZipInputStream.read(ZipInputStream.java:193)
      at java.io.BufferedInputStream.fill(BufferedInputStream.java:235)
      at java.io.BufferedInputStream.read(BufferedInputStream.java:254)
      at org.jacoco.core.internal.analysis.ContentTypeDetector.readInt(ContentTypeDetector.java:81)
      at org.jacoco.core.internal.analysis.ContentTypeDetector.determineType(ContentTypeDetector.java:61)
      at org.jacoco.core.internal.analysis.ContentTypeDetector.<init>(ContentTypeDetector.java:56)
      at org.jacoco.core.analysis.Analyzer.analyzeAll(Analyzer.java:152)
      at org.jacoco.core.analysis.Analyzer.analyzeArchive(Analyzer.java:135)
      at org.jacoco.core.analysis.Analyzer.analyzeAll(Analyzer.java:158)
      at org.jacoco.core.analysis.Analyzer.analyzeAll(Analyzer.java:183)
      at org.jacoco.core.analysis.Analyzer.analyzeAll(Analyzer.java:178)
      at org.jacoco.core.analysis.Analyzer.analyzeAll(Analyzer.java:178)
      at org.jacoco.core.analysis.Analyzer.analyzeAll(Analyzer.java:178)
      at hudson.plugins.jacoco.ExecutionFileLoader.analyzeStructure(ExecutionFileLoader.java:110)
      at hudson.plugins.jacoco.ExecutionFileLoader.loadBundleCoverage(ExecutionFileLoader.java:116)
      at hudson.plugins.jacoco.JacocoBuildAction.getJacocoReports(JacocoBuildAction.java:236)
      at hudson.plugins.jacoco.JacocoBuildAction.loadRatios(JacocoBuildAction.java:319)
      at hudson.plugins.jacoco.JacocoBuildAction.load(JacocoBuildAction.java:300)
      at hudson.plugins.jacoco.JacocoPublisher.perform(JacocoPublisher.java:214)
      at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:45)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:772)
      at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:736)
      at hudson.model.Build$BuildExecution.post2(Build.java:183)
      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:685)
      at hudson.model.Run.execute(Run.java:1757)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:234)

      This fails the job and there is no coverage report.

      I don't know exactly what causes it but the problem reproduces every build.
      It may be related to the fact that the project has grown over time and it contains big resource files.

      Attachments

        Activity

          centic centic added a comment -

          Sounds like a broken Zip/Jar file in your build-output, but can you first try with the latest version 1.0.16 of JaCoCo-plugin, I think you are running a fairly old version from 2 years ago, it might very well be fixed since then.

          centic centic added a comment - Sounds like a broken Zip/Jar file in your build-output, but can you first try with the latest version 1.0.16 of JaCoCo-plugin, I think you are running a fairly old version from 2 years ago, it might very well be fixed since then.
          centic centic added a comment -

          No answer for a long time.

          centic centic added a comment - No answer for a long time.

          People

            ognjenb Ognjen Bubalo
            ariezilberstein Arie Zilberstein
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: