Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-25563

ViewVC links for classic CVS integration are not generated

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      The ViewVC integration is not working if I configure it under advanced repository properties on the classic "CVS" integration.

      If I configure the ViewVC repository browser on the "CVS Projectset" the links are shown correctly.

      I am using Jenkins 1.580.1 LTS on tomcat 6 and CVS Plugin v2.12 and ViewVC Plugin v1.7.

        Attachments

          Activity

          Hide
          ralf_o ralf oyen added a comment -

          Same problem for me. CVS Plugin v2.8 works correctly.

          Show
          ralf_o ralf oyen added a comment - Same problem for me. CVS Plugin v2.8 works correctly.
          Hide
          neon Neon Ngo added a comment - - edited

          Similar issue, under SCM > Source Code Management > Advanced Repository Options > Repository browser
          I do not have a ViewVC option from the drop down selection box.
          Although, I do have a ViewCVS option, but that is also not working even after I set the server's URL

          I am using Jenkins 1.625.1 LTS and CVS Plugin v2.11 and ViewVC Plugin v1.7.

          Show
          neon Neon Ngo added a comment - - edited Similar issue, under SCM > Source Code Management > Advanced Repository Options > Repository browser I do not have a ViewVC option from the drop down selection box. Although, I do have a ViewCVS option, but that is also not working even after I set the server's URL I am using Jenkins 1.625.1 LTS and CVS Plugin v2.11 and ViewVC Plugin v1.7.
          Hide
          toleary Terry O'Leary added a comment -

          Same issue for me. I am able to see changes in the job, however, they no longer link the way my old Jenkins used to.

          Current config: Jenkins 2.65 / CVS plugin 2.13 / and ViewVC plugin 1.7 

          Old config: Jenkins 1.534 / CVS plugin 1.6 / and ViewVC plugin 1.6 

          The version of ViewVC I have is 1.1.26 on the CVS repository and it works on the old Jenkins server I have been keeping around for reference if needed.

          Attached is an example picture of the OLD Jenkins showing the link in the changes of one of the jobs:

          and also attached is a picture of NEW Jenkins showing the changes of one of the jobs with no link:

          Both jobs have "Repository Browser" set to ViewVC as the selection in the drop down with the same URI.

          Show
          toleary Terry O'Leary added a comment - Same issue for me. I am able to see changes in the job, however, they no longer link the way my old Jenkins used to. Current config: Jenkins 2.65 / CVS plugin 2.13 / and ViewVC plugin 1.7  Old config:  Jenkins 1.534 / CVS plugin 1.6 / and ViewVC plugin 1.6  The version of ViewVC I have is 1.1.26 on the CVS repository and it works on the old Jenkins server I have been keeping around for reference if needed. Attached is an example picture of the OLD Jenkins showing the link in the changes of one of the jobs: and also attached is a picture of NEW Jenkins showing the changes of one of the jobs with no link: Both jobs have "Repository Browser" set to ViewVC as the selection in the drop down with the same URI.
          Hide
          io39d io39d added a comment -

          The issue seems to be in the cvs-plugin. Same issue as described in ticket JENKINS-29985 

          Show
          io39d io39d added a comment - The issue seems to be in the cvs-plugin. Same issue as described in ticket  JENKINS-29985  

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            hidminds Daniel Fischer
            Votes:
            4 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated: