Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-26560

Too long description of BuildResutUUID that team Concert Plugin creates makes editing difficult

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: teamconcert-plugin
    • Labels:
      None
    • Environment:
      Jenkin 1.592, teamconcert-plugin 1.1.9
    • Similar Issues:

      Description

      Once a build is kicked off with a Jenkins/Team Concert integration, the Team Concert plugin updates the Jenkins job definition with a "buildResultUUID" parameter, and includes a very long description of this parameter, as follows:

      The UUID of the build result in RTC. It is supplied by builds initiated through RTC. For builds initiated through Hudson/Jenkins, no value should be supplied.

      This 3-sentence description is added without new line characters (or line breaks). After this parameter and its description are added to a Jenkins build definition, then during subsequent edits of the jenkins job configuration, Jenkins uses the width of the widest field as the page width of the browser. This very long description for buildResultUUID's description is placed in a edit box field without wrapping the description to a reasonable width. Hence, all of the edit fields which are presented by Jenkins in the browser go way off to the right of the browser window (to at least the width of this description, including the Delete buttons for each editable configuration which are right-justified to align up with the right edge of all of the edit fields. This makes the Delete buttons very difficult to find.

      Could this description be shortened, or at least include line ends (<br>, after each sentence, so that the displayed width of this field is much reduced withing the browser, and so less scrolling and hunting for the Delete button is required.

        Attachments

          Activity

          hfraserdube Heather Fraser-Dube added a comment -

          We are running Jenkins 1.596. I have builds defined with a long description for a build parameter and it wraps nicely. Seems like Jenkins has fixed their issue.

          lvaikunt Lakshmi Narasimhan Vaikuntam added a comment -

          The description text looks proper. Tried with Jenkins 2.19. Closing.

          Reopen if the issue is still reproducible.

          rickybobpat Rick Patterson added a comment -

          Yes, I can confirm seems to be fixed   We have upgraded to jenkins 2.46.3 and  team-concert plugin is at 1.2.0.0, and now this field is in a scrollable field, and no longer is too wide.


            People

            Assignee:
            lvaikunt Lakshmi Narasimhan Vaikuntam
            Reporter:
            rickybobpat Rick Patterson
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: