Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-27187

Failed to initialize plugin greenballs

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: greenballs-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.600
      greenballs version: 1.14
    • Similar Issues:

      Description

      Hello,

      after updating Jenkins from 1.599 to 1.600 i see blue balls instead of green.

      I saw that stacktrace in the jenkins log:

      {code] [#|2015-03-02T08:14:27.354+0100|SEVERE|glassfish3.0.1|jenkins.InitReactorRunner|_ThreadID=71;_ThreadName=Thread-1;|Failed Loading plugin greenballs java.io.IOException: Failed to initialize at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:439) at hudson.PluginManager$2$1$1.run(PluginManager.java:370) at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169) at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282) at jenkins.model.Jenkins$7.runTask(Jenkins.java:903) at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210) at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) at java.lang.Thread.run(Thread.java:722) Caused by: java.lang.NullPointerException at hudson.util.PluginServletFilter.addFilter(PluginServletFilter.java:99) at hudson.plugins.greenballs.PluginImpl.start(PluginImpl.java:40) at hudson.ClassicPluginStrategy.startPlugin(ClassicPluginStrategy.java:447) at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:436) ... 9 more |#] {code}

        Attachments

          Activity

          nfalco Nikolas Falco added a comment -

          The NPE happens in PluginServletFilter that is part of Jenkins Core and with Jenkins 1.625.3 fix the issue.


            People

            Assignee:
            nfalco Nikolas Falco
            Reporter:
            sfin Sven Finsterwalder
            Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: