Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-27461

Git polling shows exception when job is currently running

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Critical
    • Resolution: Postponed
    • git-client-plugin
    • Jenkins 1.596.1 LTS
      git-client-plugin 1.16.1 (also tested 1.15)
      git-plugin 1.6 (also tested 1.5)

      running on
      Ubuntu 14.04 LTS
      with local git installation 1.9.1

    Description

      I use git polling to trigger my jobs. I recognized a Exception within the "Git Polling Log":

      Started on 17.03.2015 15:40:08
      Using strategy: Default
      [poll] Last Built Revision: Revision ae505d729d3b76e43782b351d7628024e065db61 (refs/remotes/origin/master)
      ERROR: Failed to record SCM polling for hudson.maven.MavenModuleSet@42caa9c4[(BUILD) mp-modules master unit]
      java.lang.RuntimeException: Unable to determine Maven version
      	at org.jfrog.hudson.maven3.extractor.MavenExtractorEnvironment.isMavenVersionValid(MavenExtractorEnvironment.java:151)
      	at org.jfrog.hudson.maven3.extractor.MavenExtractorEnvironment.buildEnvVars(MavenExtractorEnvironment.java:106)
      	at hudson.model.AbstractBuild.getEnvironment(AbstractBuild.java:914)
      	at hudson.maven.AbstractMavenBuild.getEnvironment(AbstractMavenBuild.java:56)
      	at hudson.maven.MavenModuleSetBuild.getEnvironment(MavenModuleSetBuild.java:167)
      	at hudson.plugins.git.GitSCM.compareRemoteRevisionWithImpl(GitSCM.java:564)
      	at hudson.plugins.git.GitSCM.compareRemoteRevisionWith(GitSCM.java:526)
      	at hudson.scm.SCM.compareRemoteRevisionWith(SCM.java:380)
      	at hudson.scm.SCM.poll(SCM.java:397)
      	at hudson.model.AbstractProject._poll(AbstractProject.java:1446)
      	at hudson.model.AbstractProject.poll(AbstractProject.java:1349)
      	at jenkins.triggers.SCMTriggerItem$SCMTriggerItems$Bridge.poll(SCMTriggerItem.java:119)
      	at hudson.triggers.SCMTrigger$Runner.runPolling(SCMTrigger.java:515)
      	at hudson.triggers.SCMTrigger$Runner.run(SCMTrigger.java:544)
      	at hudson.util.SequentialExecutionQueue$QueueEntry.run(SequentialExecutionQueue.java:118)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
      	at java.lang.Thread.run(Thread.java:745)
      Caused by: java.lang.NullPointerException
      	at org.jfrog.hudson.util.MavenVersionHelper.getMavenInstallation(MavenVersionHelper.java:105)
      	at org.jfrog.hudson.util.MavenVersionHelper.isAtLeastVersion(MavenVersionHelper.java:81)
      	at org.jfrog.hudson.util.MavenVersionHelper.isAtLeastResolutionCapableVersion(MavenVersionHelper.java:72)
      	at org.jfrog.hudson.maven3.extractor.MavenExtractorEnvironment.isMavenVersionValid(MavenExtractorEnvironment.java:149)
      	... 19 more
      

      The exception occurs when the the git polling is triggered while the job is already in progress. The changes will not be polled again. If there is another change after the job has finished also the changes in the aborted poll will be build.

      Attachments

        Activity

          The exception is caused by the artifactory plugin. Created a new issue in their Jira: https://www.jfrog.com/jira/browse/HAP-583

          nieschinhio Michael Niestegge added a comment - The exception is caused by the artifactory plugin. Created a new issue in their Jira: https://www.jfrog.com/jira/browse/HAP-583

          People

            ndeloof Nicolas De Loof
            nieschinhio Michael Niestegge
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: