Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-27551

tox builder no longer working with tox 1.9.1 because pip is too old and upstream tox does not include the dependency

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      See https://bitbucket.org/hpk42/tox/issue/228/tox-doesnt-work-with-older-pip-versions for the description of the breakage.

      Two things that can be done:

      • Bump the version of virtualenv and pip used in the plugin (should be done anyway IMO)
      • Allow to specify the exact version of tox to use - and/or allow the usage of system tox

      This change basically renders our tox builds unusable until upstream fixes their problem, which is not great in an environment where all the versions are usually fixed. It would be very very nice to allow the system python (i.e. the python that is going to be used by the tox builder) to be used for all these packages as that would put the burden of maintaining their versions not on the plugin author but on the user of jenkins.

      Happy to create a pull request if that's what's necessary

        Attachments

          Activity

          Hide
          mansion Olivier Mansion added a comment -

          just release the 0.22 with the latest virtualenv

          Show
          mansion Olivier Mansion added a comment - just release the 0.22 with the latest virtualenv

            People

            Assignee:
            mansion Olivier Mansion
            Reporter:
            vladimir_lu_work Vladimir Lu
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: