Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-27985

Slack post may have failed. Response: Private integrations can't post to public channels

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Not A Defect
    • Component/s: slack-plugin
    • Labels:
    • Environment:
      Windows 7 x64
      Jenkins 1.609
      Slack plugin 1.7
    • Similar Issues:

      Description

      Upon trying to use the slack plugin via a git commit triggered build on my jenkins server, I get this error on my jenkins log:

      Apr 16, 2015 1:42:37 PM INFO jenkins.plugins.slack.StandardSlackService publish
      Posting: to #ekko_project on sensoft using https://sensoft.slack.com/services/hooks/jenkins-ci?token=k2G8FiYNauB9DzSHKBwmaDrI: EKKO_Project - #6602 Success after 58 sec (<http://bounds-pc:8080/job/EKKO_Project/6602/|Open>) green
      Apr 16, 2015 1:42:37 PM WARNING jenkins.plugins.slack.StandardSlackService publish

      Slack post may have failed. Response: Private integrations can't post to public channels

        Attachments

          Activity

          ben_slaughter ben slaughter added a comment -

          I had a similar issue, This could be because you added the integration to Slack as a private integration (added to your own profile) and therefore can only post to Direct message, and the private room you have access to.
          If you are a Slack admin, try and add the integration to your slack team, this should give the integration the ability to post to public rooms.

          sag47 Sam Gleske added a comment -

          So this is a limitation imposed by slack. I would consider this not a bug and defer to ben slaughter's workaround or using a public integration.

          mconte Matthew Conte added a comment -

          Yes, that was indeed the issue. I had my Admin create a public integration for my team to post to public channels on Jenkins events. Thank You!


            People

            Assignee:
            sag47 Sam Gleske
            Reporter:
            mconte Matthew Conte
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: