Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-28012

"Failed to parse POMs" during archiving of poms when running maven job

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
    • Similar Issues:

      Description

      When running a jenkins maven job with Jenkins 1610 it suddenly fails with ERROR: Failed to parse POMs

      This has occurred to us three different jobs. Stack traces are as follows:

      [JENKINS] Archiving /home/jenkins/workspace/wimbledon-branches/wimbledon-persistence/target/wimbledon-persistence-3.0-SNAPSHOT.jar to de.wolterskluwer.cms.wimbledon/wimbledon-persistence/3.0-SNAPSHOT/wimbledon-persistence-3.0-SNAPSHOT.jar
      ERROR: Failed to parse POMs
      java.io.IOException: Failed to extract /home/jenkins/workspace/wimbledon-branches/wimbledon-persistence/transfer of 2 files
      	at hudson.FilePath.readFromTar(FilePath.java:2299)
      	at hudson.FilePath.copyRecursiveTo(FilePath.java:2208)
      	at jenkins.model.StandardArtifactManager.archive(StandardArtifactManager.java:61)
      	at hudson.maven.MavenBuild$ProxyImpl.performArchiving(MavenBuild.java:483)
      	at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:851)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:536)
      	at hudson.model.Run.execute(Run.java:1741)
      	at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:531)
      	at hudson.model.ResourceController.execute(ResourceController.java:98)
      	at hudson.model.Executor.run(Executor.java:374)
      Caused by: java.io.IOException: Truncated TAR archive
      	at org.apache.commons.compress.archivers.tar.TarArchiveInputStream.read(TarArchiveInputStream.java:614)
      	at java.io.InputStream.read(InputStream.java:82)
      	at org.apache.commons.io.IOUtils.copyLarge(IOUtils.java:1792)
      	at org.apache.commons.io.IOUtils.copyLarge(IOUtils.java:1769)
      	at org.apache.commons.io.IOUtils.copy(IOUtils.java:1744)
      	at hudson.util.IOUtils.copy(IOUtils.java:40)
      	at hudson.FilePath.readFromTar(FilePath.java:2289)
      	... 9 more
      channel stopped
      
      
      [JENKINS] Archiving /home/jenkins/workspace/metade-wkde2pci/target/wkde2pci.zip to com.wolterskluwer.services.configurations.conversion/wkde2pci/2.0-20150420.064736-13/wkde2pci-2.0-20150420.064736-13.zip
      ERROR: Failed to parse POMs
      java.io.IOException: Failed to extract /home/jenkins/workspace/metade-wkde2pci/transfer of 3 files
      	at hudson.FilePath.readFromTar(FilePath.java:2299)
      	at hudson.FilePath.copyRecursiveTo(FilePath.java:2208)
      	at jenkins.model.StandardArtifactManager.archive(StandardArtifactManager.java:61)
      	at hudson.maven.MavenBuild$ProxyImpl.performArchiving(MavenBuild.java:483)
      	at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:851)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:536)
      	at hudson.model.Run.execute(Run.java:1741)
      	at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:531)
      	at hudson.model.ResourceController.execute(ResourceController.java:98)
      	at hudson.model.Executor.run(Executor.java:374)
      Caused by: java.io.IOException: Truncated TAR archive
      	at org.apache.commons.compress.archivers.tar.TarArchiveInputStream.read(TarArchiveInputStream.java:614)
      	at java.io.InputStream.read(InputStream.java:82)
      	at org.apache.commons.io.IOUtils.copyLarge(IOUtils.java:1792)
      	at org.apache.commons.io.IOUtils.copyLarge(IOUtils.java:1769)
      	at org.apache.commons.io.IOUtils.copy(IOUtils.java:1744)
      	at hudson.util.IOUtils.copy(IOUtils.java:40)
      	at hudson.FilePath.readFromTar(FilePath.java:2289)
      	... 9 more
      
      
      [JENKINS] Archiving /home/jenkins/workspace/lexdb-legacy/lexdb-oracle-urteilid/target/lexdb-oracle-urteilid-3.8.33-SNAPSHOT.jar to de.lexisnexis.lexdb/lexdb-oracle-urteilid/3.8.33-SNAPSHOT/lexdb-oracle-urteilid-3.8.33-SNAPSHOT.jar
      ERROR: Failed to parse POMs
      java.io.IOException: Failed to extract /home/jenkins/workspace/lexdb-legacy/lexdb-oracle-urteilid/transfer of 2 files
      	at hudson.FilePath.readFromTar(FilePath.java:2299)
      	at hudson.FilePath.copyRecursiveTo(FilePath.java:2208)
      	at jenkins.model.StandardArtifactManager.archive(StandardArtifactManager.java:61)
      	at hudson.maven.MavenBuild$ProxyImpl.performArchiving(MavenBuild.java:483)
      	at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:851)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:536)
      	at hudson.model.Run.execute(Run.java:1741)
      	at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:531)
      	at hudson.model.ResourceController.execute(ResourceController.java:98)
      	at hudson.model.Executor.run(Executor.java:374)
      Caused by: java.io.IOException: Truncated TAR archive
      	at org.apache.commons.compress.archivers.tar.TarArchiveInputStream.read(TarArchiveInputStream.java:614)
      	at java.io.InputStream.read(InputStream.java:82)
      	at org.apache.commons.io.IOUtils.copyLarge(IOUtils.java:1792)
      	at org.apache.commons.io.IOUtils.copyLarge(IOUtils.java:1769)
      	at org.apache.commons.io.IOUtils.copy(IOUtils.java:1744)
      	at hudson.util.IOUtils.copy(IOUtils.java:40)
      	at hudson.FilePath.readFromTar(FilePath.java:2289)
      	... 9 more
      
      

        Attachments

        1. pom.xml
          4 kB
          Daniel Hiller

          Issue Links

            Activity

            dhiller Daniel Hiller added a comment -

            I've attached the pom anyway

            oleg_nenashev Oleg Nenashev added a comment -

            JENKINS-10629 updated Tar compression libs (from a legacy 3-years old impl to a modern commons-compress). So JENKINS-10629 should be blamed for any compression bug by default.

            I needed the file to reproduce the compression/decompression flow and to catch the issue

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Oleg Nenashev
            Path:
            core/pom.xml
            core/src/main/java/hudson/FilePath.java
            core/src/main/java/hudson/org/apache/tools/tar/TarInputStream.java
            core/src/main/java/hudson/org/apache/tools/tar/TarOutputStream.java
            core/src/main/java/hudson/util/io/TarArchiver.java
            http://jenkins-ci.org/commit/jenkins/ca21c65bf2538982126bd465eb70840071a61e4e
            Log:
            Merge pull request #1667 from oleg-nenashev/JENKINS-10629-FIX

            [JENKINS-28013,JENKINS-28012] - Revert changes for JENKINS-10629

            Compare: https://github.com/jenkinsci/jenkins/compare/8c94920973c4...ca21c65bf253

            danielbeck Daniel Beck added a comment -

            Resolved by reverting the fix for JENKINS-10629.

            integer Kanstantsin Shautsou added a comment -

            Please try new build and reply https://jenkins.ci.cloudbees.com/job/core/job/jenkins-core/2480/artifact/war/target/jenkins.war . It should support >8GB files and doesn't corrupt POMs.


              People

              Assignee:
              oleg_nenashev Oleg Nenashev
              Reporter:
              dhiller Daniel Hiller
              Votes:
              3 Vote for this issue
              Watchers:
              13 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: