Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-28105

deployment failed

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: deploy-plugin
    • Labels:
    • Environment:
      jenkins 1.607,java 1.7,tomcat 7.0.54
    • Similar Issues:

      Description

      Deploying /usr/local/apache-tomcat-7.0.54/webapps/jenkins/jobs/buildproject/workspace/AntExample1/dist/AntExample.war to container Tomcat 7.x Remote
      ERROR: Build step failed with exception
      org.codehaus.cargo.container.ContainerException: Failed to redeploy [/usr/local/apache-tomcat-7.0.54/webapps/jenkins/jobs/buildproject/workspace/AntExample1/dist/AntExample.war]
      at org.codehaus.cargo.container.tomcat.internal.AbstractTomcatManagerDeployer.redeploy(AbstractTomcatManagerDeployer.java:189)
      at hudson.plugins.deploy.CargoContainerAdapter.deploy(CargoContainerAdapter.java:73)
      at hudson.plugins.deploy.CargoContainerAdapter$1.invoke(CargoContainerAdapter.java:116)
      at hudson.plugins.deploy.CargoContainerAdapter$1.invoke(CargoContainerAdapter.java:103)
      at hudson.FilePath.act(FilePath.java:989)
      at hudson.FilePath.act(FilePath.java:967)
      at hudson.plugins.deploy.CargoContainerAdapter.redeploy(CargoContainerAdapter.java:103)
      at hudson.plugins.deploy.DeployPublisher.perform(DeployPublisher.java:61)
      at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:45)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:761)
      at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:721)
      at hudson.model.Build$BuildExecution.post2(Build.java:183)
      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:670)
      at hudson.model.Run.execute(Run.java:1766)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:98)
      at hudson.model.Executor.run(Executor.java:374)
      Caused by: org.codehaus.cargo.container.tomcat.internal.TomcatManagerException: The username you provided is not allowed to use the text-based Tomcat Manager (error 403)
      at org.codehaus.cargo.container.tomcat.internal.TomcatManager.invoke(TomcatManager.java:555)
      at org.codehaus.cargo.container.tomcat.internal.TomcatManager.list(TomcatManager.java:686)
      at org.codehaus.cargo.container.tomcat.internal.TomcatManager.getStatus(TomcatManager.java:699)
      at org.codehaus.cargo.container.tomcat.internal.AbstractTomcatManagerDeployer.redeploy(AbstractTomcatManagerDeployer.java:174)
      ... 16 more
      Caused by: java.io.IOException: Server returned HTTP response code: 403 for URL: http://localhost:2020/manager/text/list
      at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1626)
      at org.codehaus.cargo.container.tomcat.internal.TomcatManager.invoke(TomcatManager.java:544)
      ... 19 more
      org.codehaus.cargo.container.tomcat.internal.TomcatManagerException: The username you provided is not allowed to use the text-based Tomcat Manager (error 403)
      at org.codehaus.cargo.container.tomcat.internal.TomcatManager.invoke(TomcatManager.java:555)
      at org.codehaus.cargo.container.tomcat.internal.TomcatManager.list(TomcatManager.java:686)
      at org.codehaus.cargo.container.tomcat.internal.TomcatManager.getStatus(TomcatManager.java:699)
      at org.codehaus.cargo.container.tomcat.internal.AbstractTomcatManagerDeployer.redeploy(AbstractTomcatManagerDeployer.java:174)
      at hudson.plugins.deploy.CargoContainerAdapter.deploy(CargoContainerAdapter.java:73)
      at hudson.plugins.deploy.CargoContainerAdapter$1.invoke(CargoContainerAdapter.java:116)
      at hudson.plugins.deploy.CargoContainerAdapter$1.invoke(CargoContainerAdapter.java:103)
      at hudson.FilePath.act(FilePath.java:989)
      at hudson.FilePath.act(FilePath.java:967)
      at hudson.plugins.deploy.CargoContainerAdapter.redeploy(CargoContainerAdapter.java:103)
      at hudson.plugins.deploy.DeployPublisher.perform(DeployPublisher.java:61)
      at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:45)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:761)
      at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:721)
      at hudson.model.Build$BuildExecution.post2(Build.java:183)
      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:670)
      at hudson.model.Run.execute(Run.java:1766)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:98)
      at hudson.model.Executor.run(Executor.java:374)
      Caused by: java.io.IOException: Server returned HTTP response code: 403 for URL: http://localhost:2020/manager/text/list
      at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1626)
      at org.codehaus.cargo.container.tomcat.internal.TomcatManager.invoke(TomcatManager.java:544)
      ... 19 more
      Build step 'Deploy war/ear to a container' marked build as failure
      Finished: FAILURE

        Attachments

          Activity

          jansohn Robin Jansohn added a comment -

          HTTP response code 403 means wrong credentials. Nothing to fix here...


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            bujjidd bujji dd
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: