Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-28355

Project's Build History frame size is short for icons

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Trivial
    • Resolution: Duplicate
    • Component/s: core
    • Environment:
      Linux , Jenkins 1.611, Gerrit, Artifactory, Bintray, Groovy plugins
      IE and Chrome browsers
    • Similar Issues:

      Description

      Issue started from upgrading Jenkins from 1.596 to 1.611

      Project build history table in the left side of Project Dashboard is not wide enough for different plugin icons. Wide Size of the table is not dynamically changed if build icons added by different plugins. My project builds have gerrit link icon, several artifactory icons and bintray icon. Total size of the table line is not matched with table size. This is visible on attached screenshot picture.

      The easiest way to reproduce this issue is to install Groovy Postbuild plugin and add the following Groovy script to any simple shell project :

      _def matcher = manager.getMatcher(manager.build.logFile, "^Total time: (.*)\$")
      if(matcher?.matches()) {
      manager.addShortText(matcher.group(1), "grey", "white", "0px", "white")
      }
      manager.addShortText("TaTaTaTaTaTaTaTa")
      manager.addBadge("star-gold.gif", "icon from Hudson")
      manager.addBadge("yellow.gif", "icon from groovy-postbuild plugin")
      manager.addBadge("/images/16x16/yellow.gif", "icon from Hudson")
      manager.addBadge("/plugin/greenballs/16x16/green.gif", "icon from greenballs plugin")

      _

      Do we have temporary walk around to change manually build history table hard coded wide size ?

        Attachments

          Activity

          danielbeck Daniel Beck added a comment -

          This looks like a duplicate of JENKINS-28425 resolved in Jenkins 1.615.


            People

            Assignee:
            pavel Pavel C
            Reporter:
            pavel Pavel C
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: