Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-28391

Allow excluding files from "Manual synchronization includes"

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Not all plugins use the same naming convention for their xml configuration file. Thus an include filter such as

      hudson.*xml jenkins*xml *plugin*.xml

      doesn't capture all plugin configurations. But if one uses *xml then one also includes credentials.xml. If one lists all plugin xml then one needs to update the filter when installing new plugins. It would be nice if one could specify both an include and an exclude filter so that one could specify:
      include: *xml
      exclude: credentials.xml

        Attachments

          Issue Links

            Activity

            rschulz Roland Schulz created issue -
            rschulz Roland Schulz made changes -
            Field Original Value New Value
            Description Not all plugins use the same naming convention for their xml configuration file. Thus an include filter such as "hudson.*xml jenkins*xml *plugin*.xml" doesn't capture all plugin configurations. But if one uses *xml then one also includes credentials.xml. If one lists all plugin xml then one needs to update the filter when installing new plugins. It would be nice if one could specify both an include and an exclude filter so that one could specify:
            include: *xml
            exclude: credentials.xml
            Not all plugins use the same naming convention for their xml configuration file. Thus an include filter such as {noformat}hudson.*xml jenkins*xml *plugin*.xml{noformat} doesn't capture all plugin configurations. But if one uses *xml then one also includes credentials.xml. If one lists all plugin xml then one needs to update the filter when installing new plugins. It would be nice if one could specify both an include and an exclude filter so that one could specify:
            include: *xml
            exclude: credentials.xml
            fcamblor Frédéric Camblor made changes -
            Link This issue is related to JENKINS-19659 [ JENKINS-19659 ]
            fcamblor Frédéric Camblor made changes -
            Link This issue duplicates JENKINS-18187 [ JENKINS-18187 ]
            fcamblor Frédéric Camblor added a comment -

            Duplicate of JENKINS-18187

            A more generic solution has been proposed in JENKINS-19659. What do you think about it ?
            Are you ok to close current issue ?

            rschulz Roland Schulz added a comment -

            I don't think 19659 addresses my issue. I do agree this is a duplicate of 18187. Sorry! I think it is probably better to have the discussion in one place. So I'll put my reason why I think this is a good feature there and this should be closed as duplicate.

            rschulz Roland Schulz made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Resolved [ 5 ]
            rschulz Roland Schulz made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            fcamblor Frédéric Camblor added a comment -

            Fine, thanks

            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 163230 ] JNJira + In-Review [ 208774 ]

              People

              Assignee:
              fcamblor Frédéric Camblor
              Reporter:
              rschulz Roland Schulz
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: