Currently the "project name" is the only way to refer to a credential, e.g. via GoogleRobotCredentials.getById(projectName);
However as this is a free text field, users can rename the credential, and jobs configured to use that credential (having stored the "project name" value, aka "id" in the job config) will no longer work.
Other credential types seem to use the id field to store a stable UUID value (which isn't shown to the user), e.g.
So it seems like id here should really be projectName — it would be nice if this plugin used the id field in the same way as other credential plugins.