Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-29140

Temporary file appears to leak data

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Trivial
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      Master. Debian Linux 7, openjdk-7-jre, 7u79-2.5.5-1~deb7u1, amd64, Jenkins 1.617 from package repository.
      Build Slave: Windows 2012R2, Oracle Java 8 update 45, x64
    • Similar Issues:

      Description

      While monitoring an archive operation in order to investigate Jenkins-29137 I spotted a strangely named file -

      rw-rr- 1 jenkins jenkins 2553815040 Jun 30 11:11 $eip $T0 ^ = $esp $T0 4 + =

      This file is growing so looks to be the currently working file and the file name looks suspiciously like Java Byte code. Random file name generation managing to read unclean data from the heap?

        Attachments

          Issue Links

            Activity

            danielbeck Daniel Beck added a comment -

            Where is the file located?

            marksyms Mark Syms added a comment -

            In the build archive folder

            {Build Record Root Directory}

            /<Job Name>/<Build Number>/archive

            marksyms Mark Syms added a comment -

            The build finally failed with -

            Archiving artifacts
            ERROR: Failed to archive artifacts: <Artefacts>
            java.io.IOException: Failed to extract e:\workspace_<Job Name>_/transfer of 18325 files
            at hudson.FilePath.readFromTar(FilePath.java:2299)
            at hudson.FilePath.copyRecursiveTo(FilePath.java:2210)
            at jenkins.model.StandardArtifactManager.archive(StandardArtifactManager.java:61)
            at hudson.tasks.ArtifactArchiver.perform(ArtifactArchiver.java:219)
            at hudson.tasks.BuildStepCompatibilityLayer.perform(BuildStepCompatibilityLayer.java:75)
            at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
            at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:779)
            at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:726)
            at hudson.model.Build$BuildExecution.post2(Build.java:185)
            at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:671)
            at hudson.model.Run.execute(Run.java:1769)
            at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
            at hudson.model.ResourceController.execute(ResourceController.java:98)
            at hudson.model.Executor.run(Executor.java:374)
            Caused by: java.io.IOException: unexpected EOF with 2560 bytes unread
            at hudson.org.apache.tools.tar.TarInputStream.read(TarInputStream.java:349)
            at java.io.FilterInputStream.read(FilterInputStream.java:107)
            at org.apache.commons.io.IOUtils.copyLarge(IOUtils.java:1792)
            at org.apache.commons.io.IOUtils.copyLarge(IOUtils.java:1769)
            at org.apache.commons.io.IOUtils.copy(IOUtils.java:1744)
            at hudson.util.IOUtils.copy(IOUtils.java:40)
            at hudson.FilePath.readFromTar(FilePath.java:2289)
            ... 13 more
            Build step 'Archive the artifacts' changed build result to FAILURE

            danielbeck Daniel Beck added a comment -

            No idea where the file name is from, but note that if you're beyond 8GB, Jenkins archiving will fail. There are proposed fixes, but none are in yet.

            marksyms Mark Syms added a comment -

            I think it probably was from exceeding the 8GB limit, I'm "tweaking" the build to split the output. Not nice that it can generate this though.

            oleg_nenashev Oleg Nenashev added a comment -

            Closing as a duplicate of JENKINS-10629
            Fixed in Jenkins 1.629


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              marksyms Mark Syms
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: