Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-29843

Can't install Sauce OnDemand Plugin

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: sauce-ondemand-plugin
    • Labels:
      None
    • Environment:
    • Similar Issues:

      Description

      When trying to install the Sauce OnDemand plugin via 'Install without restart' as well as 'Download now and install after restart' I receive the following error:

      java.io.IOException: Failed to dynamically deploy this plugin
      	at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1317)
      	at hudson.model.UpdateCenter$DownloadJob.run(UpdateCenter.java:1116)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
      	at hudson.remoting.AtmostOneThreadExecutor$Worker.run(AtmostOneThreadExecutor.java:104)
      	at java.lang.Thread.run(Thread.java:745)
      Caused by: java.io.IOException: Failed to install sauce-ondemand plugin
      	at hudson.PluginManager.dynamicLoad(PluginManager.java:453)
      	at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1313)
      	... 5 more
      Caused by: java.io.IOException: Failed to initialize
      	at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:396)
      	at hudson.PluginManager.dynamicLoad(PluginManager.java:444)
      	... 6 more
      Caused by: java.lang.NoClassDefFoundError: org/sonatype/guice/bean/locators/MutableBeanLocator
      	at com.saucelabs.hudson.HudsonSauceManagerFactory.start(HudsonSauceManagerFactory.java:55)
      	at hudson.plugins.sauce_ondemand.PluginImpl.start(PluginImpl.java:148)
      	at hudson.ClassicPluginStrategy.startPlugin(ClassicPluginStrategy.java:404)
      	at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:393)
      	... 7 more
      Caused by: java.lang.ClassNotFoundException: org.sonatype.guice.bean.locators.MutableBeanLocator
      	at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1375)
      	at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1325)
      	at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1078)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
      	... 11 more
      

      I have also tried installing it manually via uploading the hpi at https://updates.jenkins-ci.org/download/plugins/sauce-ondemand/
      which results in the same.

        Attachments

          Activity

          tobybro Toby Broyles added a comment -

          Sorry for the delay. I stopped jenkins and removed the directory. I left the sauce-ondemand.jpi file in place and then started it back up. I then tried the install again and received the same error.

          rossrowe Ross Rowe added a comment -

          Hi, I've just uploaded a snapshot version which removes the usage of plexus (which should hopefully resolve the issue), it's available from https://repository-saucelabs.forge.cloudbees.com/release/org/jenkins-ci/plugins/sauce-ondemand/1.141-SNAPSHOT/sauce-ondemand-1.141-20150829.073521-1.hpi, would you be able to try this version out?

          tobybro Toby Broyles added a comment -

          Success! Thank you so much for your help!

          halkeye Gavin Mogan added a comment -

          Toby Broyles: I know its been a while but is this resolved? Can I close the ticket?

          tobybro Toby Broyles added a comment -

          The snapshot has been working fine for us, you can close out this ticket. Thank you.


            People

            Assignee:
            rossrowe Ross Rowe
            Reporter:
            tobybro Toby Broyles
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: