Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-30721

Filesets on Windows shall be case insensitive

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Duplicate
    • core
    • None

    Description

      For historical reasons Windows filesystem is case insensitive (unfortunately). Although the filesystem does store case, frequently the users don't have control over the case of created file/folder names.
      Windows users expect all tools to be case agnostic. However, this is not the current situation with Jenkins.

      For example, for ArtifactDeployer Plugin on Windows, setting "Artifacts to deploy" to "Foo/**" will deploy nothing if the filesystem folder is called "foo". This is clearly not a behaviour Windows user would expect. Similar issue happens with JUnit Plugin.

      The problem root is in the usage of Ant FileSet class which is by default case sensitive (although it can be set to ignore case).

      Attachments

        Issue Links

          Activity

            teilo James Nord added a comment -

            Windows can support case sensitive file systems - indeed this is not so unusual with remoteFS - just as much as Linux can support case insensitive file systems.

            Whilst some windows users do not expect this, making any changes should be dependant on the underlying File System not the underlying platform (e.g. FAT on Linux should arguably be treated as case insensitive)

            teilo James Nord added a comment - Windows can support case sensitive file systems - indeed this is not so unusual with remoteFS - just as much as Linux can support case insensitive file systems. Whilst some windows users do not expect this, making any changes should be dependant on the underlying File System not the underlying platform (e.g. FAT on Linux should arguably be treated as case insensitive)
            teilo James Nord added a comment -

            Should be an explicit option on the tool for this behaviour.

            e.g. JENKINS-5253

            teilo James Nord added a comment - Should be an explicit option on the tool for this behaviour. e.g. JENKINS-5253
            vvv444 Vasili Galka added a comment -

            Ok, I agree. The other is older and seems a better solution, since it is configurable. Let's close this one as duplicate.

            vvv444 Vasili Galka added a comment - Ok, I agree. The other is older and seems a better solution, since it is configurable. Let's close this one as duplicate.
            vvv444 Vasili Galka added a comment -

            Duplicate of JENKINS-5253

            vvv444 Vasili Galka added a comment - Duplicate of JENKINS-5253

            People

              Unassigned Unassigned
              vvv444 Vasili Galka
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: