Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-31160

Update Jenkins UI not to call everything a "Build"

    XMLWordPrintable

Details

    • Improvement
    • Status: Open (View Workflow)
    • Minor
    • Resolution: Unresolved
    • core

    Description

      Jenkins (core, plugins, etc.) has a tendency to call everything a "build". These days, "build" tends to conjure thoughts of Continuous Integration use cases only. In fact, our very own uday wrote a plugin so users could change the "build now" button to "deploy now" (or whatever his customer's heart desired).

      There are many other areas in Jenkins where the notion of "build" is the default. This RFE requests updating them to a more fashionable term.

      It seems there are two options:

      • Jenkins either needs to be "smarter" to know there are different types of things (eg: Build Job, Test Job, Deploy Job, Pipeline)
      • Or we need a more acceptable generic word than "build" (since it seems less fashionably to point at CI use cases specifically) - eg: everything is a "job" (job history, job queue, and so on)

      Quick List of Build References:

      • Global: Build History
      • Global: Build Queue
      • Global: Build Executor Status
      • Job: Discard Old Builds
      • Job: Build Now
      • Job: Build with Parameters
      • Job: Skip Builds
      • Job: Build History
      • Job: Last build
      • Job: Last failed build
      • Job: Last unsuccessful build
      • Job: Show Consolidated Build View
      • Job: This build is parameterized
      • Job: Promote builds when...
      • Job: Disable Build
      • Job: Execute concurrent builds
      • Job: Build Triggers: *
      • Job: Build Environment: *
      • Job: Build Steps: *
      • Job: Post-build Actions: *
      • Jenkins Analytics: BUILDS PER MASTER
      • Jenkins Analytics: BUILDS

      relates to JENKINS-7628 but that ticket was closed with "Not a Bug" resolution.

      Attachments

        Issue Links

          Activity

            martinjost Martin Jost added a comment -

            Inside our CI team, we usually call a "run" (of a job), what Jenkins terms "Build",

            We have seperate jobs for actual "build" (compile/link) and "test".
            So we got several times questions from our developers, why "test" is called "Build" in CI and I had to tell, that Jenkins happens to have decided so ...

            martinjost Martin Jost added a comment - Inside our CI team, we usually call a "run" (of a job), what Jenkins terms "Build", We have seperate jobs for actual "build" (compile/link) and "test". So we got several times questions from our developers, why "test" is called "Build" in CI and I had to tell, that Jenkins happens to have decided so ...
            danielbeck Daniel Beck added a comment -

            Job: Promote builds when...

            Promoted Builds Plugin


            Job: Skip Builds
            Job: Show Consolidated Build View
            Jenkins Analytics: BUILDS PER MASTER
            Jenkins Analytics: BUILDS

            hrmpw Something for our issue tracker, these are all CJP.


            The rest appear to be in core.

            danielbeck Daniel Beck added a comment - Job: Promote builds when... Promoted Builds Plugin Job: Skip Builds Job: Show Consolidated Build View Jenkins Analytics: BUILDS PER MASTER Jenkins Analytics: BUILDS hrmpw Something for our issue tracker, these are all CJP. The rest appear to be in core.

            +2 for Run
            +1 for Execution
            -1 for keeping Build

            magjac Magnus Jacobsson added a comment - +2 for Run +1 for Execution -1 for keeping Build

            I don't suppose we're going to get consensus on this before Jenkins 2.0 — or what do you think?

            I'm working on JENKINS-33364, and I'm ending up constructing something of an English styleguide for at least the Jenkins in-app documentation (e.g. "hostname" not "host name"; "agent" not "slave") — to this end, knowing what to call agents / machines / jobs / projects / items / pipelines / builds / runs / whatever would be useful.

            orrc Christopher Orr added a comment - I don't suppose we're going to get consensus on this before Jenkins 2.0 — or what do you think? I'm working on JENKINS-33364 , and I'm ending up constructing something of an English styleguide for at least the Jenkins in-app documentation (e.g. "hostname" not "host name"; "agent" not "slave") — to this end, knowing what to call agents / machines / jobs / projects / items / pipelines / builds / runs / whatever would be useful.
            abayer Andrew Bayer added a comment -

            +1 to Run - it fits into the general feel better than "Execution".

            abayer Andrew Bayer added a comment - +1 to Run - it fits into the general feel better than "Execution".
            danielbeck Daniel Beck added a comment -

            Execution would nicely mirror the Executor term already used.

            OTOH Run would be less confusing from a developer POV as that's the common supertype for all classes implementing this.

            danielbeck Daniel Beck added a comment - Execution would nicely mirror the Executor term already used. OTOH Run would be less confusing from a developer POV as that's the common supertype for all classes implementing this.

            "Run" or "Execution" perhaps?

            magjac Magnus Jacobsson added a comment - "Run" or "Execution" perhaps?

            People

              Unassigned Unassigned
              hrmpw Patrick Wolf
              Votes:
              5 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

                Created:
                Updated: