Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-31605

Plugin manager allows uninstalling bundled plugins

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Minor
    • Resolution: Cannot Reproduce
    • core
    • Jenkins 1.638

    Description

      Introduced here:
      https://github.com/jenkinsci/jenkins/pull/1847/files#diff-c2decd7ac964b46c352a3960d1ffd9f1L114

      It's no longer relevant whether a plugin is bundled for whether it can be uninstalled. However, when you (schedule to) uninstall a bundled plugin, it'll just get reinstalled on restart.

      This check needs to be reinstated in addition to the dependencies check.

      Attachments

        Issue Links

          Activity

            teilo James Nord added a comment -

            I beleive this is now working in 2.x as there are no bundled plugins in OSS - only custom derivatives...

            teilo James Nord added a comment - I beleive this is now working in 2.x as there are no bundled plugins in OSS - only custom derivatives...

            Cannot reproduce in 2.x

            stephenconnolly Stephen Connolly added a comment - Cannot reproduce in 2.x

            I think this is still an issue. I am running 2.176.2 and I tried to uninstall the LDAP plugin. It lets me try, and I even tried actually deleting the files from /var/lib/jenkins/plugins, but after restarting, it comes back.

            haw777 Christopher Head added a comment - I think this is still an issue. I am running 2.176.2 and I tried to uninstall the LDAP plugin. It lets me try, and I even tried actually deleting the files from /var/lib/jenkins/plugins, but after restarting, it comes back.
            danielbeck Daniel Beck added a comment - - edited

            Many things about plugin management have changed in the almost three years this was filed. Please create a new issue, and describe what happened in detail there.

            danielbeck Daniel Beck added a comment - - edited Many things about plugin management have changed in the almost three years this was filed. Please create a new issue, and describe what happened in detail there.
            haw777 Christopher Head added a comment - OK. JENKINS-58580 .

            People

              tfennelly Tom FENNELLY
              danielbeck Daniel Beck
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: