Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-31928

Little/No documentation on windows slave "No tty allocated failure"

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Minor
    • Resolution: Unresolved
    • Component/s: windows-slaves-plugin
    • Labels:
    • Environment:
      os.version 3.13.0-46-generic
      java.class.version 51.0
      java.runtime.version 1.7.0_75-b13
    • Similar Issues:

      Description

      I am not able to find much documentation/help on resolving an issue with building a Jenkins job on a windows slave. I am not sure what needs to be done to fix the following issue. Here are the logs. It will be nice if the wiki is updated with some information on solving this issue

      Building remotely on Windows Slave (windows) in workspace
      c:\Builds\workspace\windows-nuget-push
      > C:\Git\cmd\git.exe rev-parse --is-inside-work-tree # timeout=10
      Fetching changes from the remote Git repository
      > C:\Git\cmd\git.exe config remote.origin.url git@github.com:SDK-NewGen/sdk.git # timeout=10
      Fetching upstream changes from git@github.com:NewGen/sdk.git
      > C:\Git\cmd\git.exe --version # timeout=10
      using GIT_SSH to set credentials 
      > C:\Git\cmd\git.exe -c core.askpass=true fetch --tags --progress git@github.com:NewGen/sdk.git +refs/heads/*:refs/remotes/origin/*
      > C:\Git\cmd\git.exe rev-parse "refs/remotes/origin/develop^{commit}" # timeout=10
      > C:\Git\cmd\git.exe rev-parse "refs/remotes/origin/origin/develop^{commit}" # timeout=10
      Checking out Revision e1feb68bcc21e8801a5bcaf087bda5041370fbf7 (refs/remotes/origin/develop)
      > C:\Git\cmd\git.exe config core.sparsecheckout # timeout=10
      > C:\Git\cmd\git.exe checkout -f e1feb68bcc21e8801a5bcaf087bda5041370fbf7
      > C:\Git\cmd\git.exe rev-list e1feb68bcc21e8801a5bcaf087bda5041370fbf7 # timeout=10
      [windows-nuget-push] $ sh -xe C:\WINDOWS\TEMP\hudson8489555376979916245.sh
            2 [main] sh 140924 tty_list::allocate_tty: No tty allocated
      + ./update-repo.sh
      C:\WINDOWS\TEMP\hudson8489555376979916245.sh: ./update-repo.sh: not found
      Build step 'Execute shell' marked build as failure
      Finished: FAILURE
      

      I think the failure is indicated by the following log message and I am not sure how to fix it.

      2 [main] sh 140924 tty_list::allocate_tty: No tty allocated,
      A quick google search pointed me to this [link]https://git.wiki.kernel.org/index.php/GitFaq#Why_does_gitk_on_Cygwin_display_.22git_1316_tty_list::allocate:_No_tty_allocated.22.3F, but I am not able to resolve this issue by removing tty from the CYGWIN environmental variable.

      Here is the shell command that is configured to be executed

      ./update-repo.sh
      ./node_modules/.bin/gulp dev
      

        Attachments

          Activity

          There are no comments yet on this issue.

            People

            Assignee:
            kohsuke Kohsuke Kawaguchi
            Reporter:
            i2infinity Amrish R
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated: