Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-320

JNLP slave error when starting build

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: Linux
    • Similar Issues:

      Description

      Hudson 1.83

      When I start a build on a remote machine that has been started with the JNLP
      client I get the following error in the console view:

      FATAL: Failed to join the process
      hudson.util.IOException2: Failed to join the process
      at hudson.Proc$RemoteProc.join(Proc.java:179)
      at hudson.scm.AbstractCVSFamilySCM.run(AbstractCVSFamilySCM.java:35)
      at hudson.scm.AbstractCVSFamilySCM.run(AbstractCVSFamilySCM.java:43)
      at hudson.scm.CVSSCM.checkout(CVSSCM.java:254)
      at hudson.scm.CVSSCM.checkout(CVSSCM.java:185)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:272)
      at hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:141)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:107)
      at hudson.model.Run.run(Run.java:533)
      at hudson.model.Build.run(Build.java:99)
      at hudson.model.Executor.run(Executor.java:61)
      Caused by: edu.emory.mathcs.backport.java.util.concurrent.ExecutionException:
      java.lang.NoSuchMethodError:
      hudson.remoting.LocalChannel.<init>(Ledu/emory/mathcs/backport/java/util/concurrent/ExecutorService;)V
      at hudson.remoting.Channel$1.adapt(Channel.java:266)
      at hudson.remoting.Channel$1.adapt(Channel.java:261)
      at hudson.remoting.FutureAdapter.get(FutureAdapter.java:32)
      at hudson.Proc$RemoteProc.join(Proc.java:171)
      ... 10 more
      Caused by: java.lang.NoSuchMethodError:
      hudson.remoting.LocalChannel.<init>(Ledu/emory/mathcs/backport/java/util/concurrent/ExecutorService;)V
      at hudson.model.Hudson$MasterComputer.<clinit>(Hudson.java:1416)
      at hudson.Launcher$LocalLauncher.<init>(Launcher.java:121)
      at hudson.model.Slave$RemoteLaunchCallable.call(Slave.java:478)
      at hudson.model.Slave$RemoteLaunchCallable.call(Slave.java:462)
      at hudson.remoting.UserRequest.perform(UserRequest.java:57)
      at hudson.remoting.UserRequest.perform(UserRequest.java:22)
      at hudson.remoting.Request$2.run(Request.java:168)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at java.lang.Thread.run(Unknown Source)

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          Should be fixed in 1.84.

          Hudson's build does some tricky things to make things work with JDK 1.4, and
          this only kicks in during the release cycle, so that's why I failed to notice
          this issue until it's too late.

          jes8 jes8 added a comment -

          I have an setup with windows xp sp3 hudson 1.350 and java jdk 1.6.0_17 and its the same jdk on all my slaves but i still get this messages too in aprox. 2 times a day 2 out 24 build gives this all of them are build remotely, can any one tell my why i get this error, i now my execution is thanking too long but sould my log say that instead of an IO exception


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            sjoerdbakker sjoerdbakker
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: