Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-32063

java.lang.NoClassDefFoundError: org/jenkinsci/plugins/tokenmacro/TokenMacro

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: token-macro-plugin
    • Labels:
      None
    • Environment:
      Ubuntu 12.04, jenkins 1.642, plugin version 1.12
    • Similar Issues:

      Description

      Total Disk Space Available is: 433Gb
      Node Name: master
      Running Prebuild steps
      FATAL: org/jenkinsci/plugins/tokenmacro/TokenMacro
      java.lang.NoClassDefFoundError: org/jenkinsci/plugins/tokenmacro/TokenMacro
      at org.jenkinsci.plugins.scriptler.builder.ScriptlerBuilder.perform(ScriptlerBuilder.java:104)
      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:782)
      at hudson.model.Build$BuildExecution.build(Build.java:205)
      at hudson.model.Build$BuildExecution.doRun(Build.java:162)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:534)
      at hudson.model.Run.execute(Run.java:1738)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:98)
      at hudson.model.Executor.run(Executor.java:410)
      Caused by: java.lang.ClassNotFoundException: org.jenkinsci.plugins.tokenmacro.TokenMacro
      at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1376)
      at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1326)
      at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1079)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
      ... 10 more

        Attachments

          Activity

          slide_o_mix Alex Earl added a comment -

          Probably not able to enable the plugin because of a cyclic issue, upgrade to 1.12.1

          bedge Bruce Edge added a comment -

          confirmed, thanks.


            People

            Assignee:
            slide_o_mix Alex Earl
            Reporter:
            bedge Bruce Edge
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: