Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-32271

ZenTimestamp plugin appears to confuse certain dates

    XMLWordPrintable

Details

    • Bug
    • Status: Fixed but Unreleased (View Workflow)
    • Major
    • Resolution: Fixed
    • zentimestamp-plugin
    • None
    • Windows, Jenkins LTS 1.596.3, ZenTimestamp 3.3

    Description

      We just encountered a very strange bug with the ZenTimestamp plugin. All of our builds from December 29th, 30th, and 31st in 2015 were all labelled with the incorrect year in the date component. For some reason all said builds claim the year to be 2016 instead of 2015!

      Builds after the new year do appear to be correct, so perhaps this is an isolated problem, but this does not build confidence in the plugin. I'd strongly urge the maintainers to review the implementation to confirm that this is not some pervading issue in the implementation that could cause incorrect date / time stamps to be generated again in the future.

      For reference, our Jenkins instance is configured to use the following build ID format string: "YYYY-MM-dd_HH-mm-ss". This pattern is set in the global Jenkins configuration and is not overridden in any of our affected CI jobs, and all builds from the 3 days mentioned, starting at midnight on December 29th appear to have been affected.

      Attachments

        Activity

          This also happened to us. Started on the 27th though, and we are on linux with the following:

          ZenTimestamper: 4.2
          OS: Centos 6
          jdk: 8
          LTS: 1.565.3
          date pattern: YYYY-MM-dd_HH-mm-ss

          makewhatis David Johansen added a comment - This also happened to us. Started on the 27th though, and we are on linux with the following: ZenTimestamper: 4.2 OS: Centos 6 jdk: 8 LTS: 1.565.3 date pattern: YYYY-MM-dd_HH-mm-ss

          Our team ran into the same issue. Discovered that the issue is due to using week year instead of year.

          date pattern should be yyyy-MM-dd_HH-mm-ss NOT YYYY-MM-dd_HH-mm-ss

          vsheffey Valarie Sheffey added a comment - Our team ran into the same issue. Discovered that the issue is due to using week year instead of year. date pattern should be yyyy -MM-dd_HH-mm-ss NOT YYYY -MM-dd_HH-mm-ss

          People

            gbois Gregory Boissinot
            leedega Kevin Phillips
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: