Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-32333

Audit Trail Plugin : can't install plugin

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: audit-trail-plugin
    • Labels:
      None
    • Environment:
    • Similar Issues:

      Description

      Can't deploy audit-trail plugin :

      INFO: Starting the installation of Audit Trail on behalf of apsvb
      Jan 07, 2016 3:28:07 PM hudson.model.UpdateCenter$UpdateCenterConfiguration download
      INFO: Downloading Audit Trail
      Jan 07, 2016 3:28:14 PM hudson.model.UpdateCenter doSafeRestart
      INFO: Scheduling Jenkins reboot

      SEVERE: Failed Loading plugin audit-trail
      java.io.IOException: Failed to initialize
      at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:441)
      at hudson.PluginManager$2$1$1.run(PluginManager.java:371)
      at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
      at jenkins.model.Jenkins$7.runTask(Jenkins.java:905)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
      at java.lang.Thread.run(Thread.java:745)
      Caused by: java.lang.IllegalArgumentException
      at java.util.logging.FileHandler.<init>(FileHandler.java:394)
      at hudson.plugins.audit_trail.LogFileAuditLogger.configure(LogFileAuditLogger.java:71)
      at hudson.plugins.audit_trail.AuditTrailPlugin.applySettings(AuditTrailPlugin.java:96)
      at hudson.plugins.audit_trail.AuditTrailPlugin.start(AuditTrailPlugin.java:68)
      at hudson.ClassicPluginStrategy.startPlugin(ClassicPluginStrategy.java:449)
      at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:438)
      ... 9 more

      an 07, 2016 3:30:53 PM jenkins.metrics.api.Metrics$HealthChecker execute
      WARNING: Some health checks are reporting as unhealthy: [plugins : There are 1 failed plugins: audit-trail]

        Attachments

          Issue Links

            Activity

            fredericmeyrou Frédéric Meyrou added a comment -

            Problem fixed after JDK 1.8 upgrade to latest version... now plugin is installing and working again.

            fredericmeyrou Frédéric Meyrou added a comment -

            Fixed after upgrade to latest JDK 1.8


              People

              Assignee:
              fredericmeyrou Frédéric Meyrou
              Reporter:
              fredericmeyrou Frédéric Meyrou
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: