Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-32382

Non-ASCII characters in the console output will be gibberish when apply mask passwords in the Job

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: mask-passwords-plugin
    • Labels:
      None
    • Environment:
      Jenkins Version:1.625.3
      Mask Passwords Plugin Version: 2.8
    • Similar Issues:

      Description

      Non-ASCII characters in the console output will be gibberish when apply mask passwords in the Job.
      If applied:

      The console output will be:

      If removed, it will back to normal:

        Attachments

        1. plug.JPG
          plug.JPG
          34 kB
        2. right.JPG
          right.JPG
          40 kB
        3. wrong.JPG
          wrong.JPG
          50 kB

          Activity

          oleg_nenashev Oleg Nenashev added a comment -

          Cannot reproduce it on my instance (used Cyrillic symbols).
          Do you use any web containers?

          ahlfors Ahlfors Lee added a comment -

          Hi Oleg, I did not put my Jenkins on Internet, could you reproduce it with a Chinese windows edition OS of Slave? I guess it might be the command line out put encoding issue, Chinese windows edition OS using GBK encoding for the command line output in default.

          oleg_nenashev Oleg Nenashev added a comment -

          Unfortunately I have no such Windows setup.
          I've tried to copy-paste several Chinese symbols from the internet, and they're being displayed well.

          > I guess it might be the command line out put encoding issue, Chinese windows edition OS using GBK encoding for the command line output in default.

          Maybe. Java should be isolated enough, but I'm not sure that Jenkins correctly handles non-UTF-8 encodings. Maybe you could verify it on a common Windows OS machine in order to confirm it.

          ahlfors Ahlfors Lee added a comment -

          OK, I will try to isolate this problem. Reply you when I have result.

          oleg_nenashev Oleg Nenashev added a comment -

          Cannot reproduce, no response from the Reporter.

          Ahlfors Lee if you have any data, feel free to reopen the ticket


            People

            Assignee:
            oleg_nenashev Oleg Nenashev
            Reporter:
            ahlfors Ahlfors Lee
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: