Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-32399

Change the name of spot instances to be more readable

    XMLWordPrintable

Details

    • Improvement
    • Status: Closed (View Workflow)
    • Minor
    • Resolution: Fixed
    • ec2-plugin
    • None

    Attachments

      Activity

        Code changed in jenkins
        User: Michael Barrientos
        Path:
        src/main/java/hudson/plugins/ec2/EC2AbstractSlave.java
        src/main/java/hudson/plugins/ec2/EC2ComputerLauncher.java
        src/main/java/hudson/plugins/ec2/EC2SpotComputerLauncher.java
        src/main/java/hudson/plugins/ec2/EC2SpotRetentionStrategy.java
        src/main/java/hudson/plugins/ec2/EC2SpotSlave.java
        src/main/java/hudson/plugins/ec2/SlaveTemplate.java
        src/main/resources/hudson/plugins/ec2/SlaveTemplate/config.jelly
        http://jenkins-ci.org/commit/ec2-plugin/ae7e53ab99028fd8ede1a3e41907812c2edb0eec
        Log:
        Poll for spot instances instead of JNLP launcher JENKINS-27529 JENKINS-19059

        • No more need for special spot startup script.
        • Changes spot slave name to use spot request ID (partially fixes JENKINS-32399)
        scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Michael Barrientos Path: src/main/java/hudson/plugins/ec2/EC2AbstractSlave.java src/main/java/hudson/plugins/ec2/EC2ComputerLauncher.java src/main/java/hudson/plugins/ec2/EC2SpotComputerLauncher.java src/main/java/hudson/plugins/ec2/EC2SpotRetentionStrategy.java src/main/java/hudson/plugins/ec2/EC2SpotSlave.java src/main/java/hudson/plugins/ec2/SlaveTemplate.java src/main/resources/hudson/plugins/ec2/SlaveTemplate/config.jelly http://jenkins-ci.org/commit/ec2-plugin/ae7e53ab99028fd8ede1a3e41907812c2edb0eec Log: Poll for spot instances instead of JNLP launcher JENKINS-27529 JENKINS-19059 No more need for special spot startup script. Changes spot slave name to use spot request ID (partially fixes JENKINS-32399 )

        This is a duplicate of JENKINS-29355. Propose to close it.

        johnny_shields Johnny Shields added a comment - This is a duplicate of JENKINS-29355 . Propose to close it.
        francisu Francis Upton added a comment -

        The spot instance id is perfect for this.

        francisu Francis Upton added a comment - The spot instance id is perfect for this.

        People

          francisu Francis Upton
          francisu Francis Upton
          Votes:
          1 Vote for this issue
          Watchers:
          4 Start watching this issue

          Dates

            Created:
            Updated:
            Resolved: