Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-32580

Plugin enable/disable information and dependencies are broken

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Minor
    • Resolution: Cannot Reproduce
    • core
    • None
    • * Jenkins 1.643
      * Debian Wheezy 64bit
      * openjdk-7-jre-headless 7u91-2.6.3-1~deb7u1
      * Tomcat6 6.0.35-6+deb7u1
      * Apache2 with jenkins_worker JKMount
      * Installed through manually deployed war file
      * Browser: Chromium 47

    Description

      The information on which plugin can be disabled or enabled based on dependencies seems to be broken.
      We have plugins that say they cannot be enabled when they actually are enabled and other plugins that say they cannot be disabled when they are disabled. See attached Screenshots.

      Attachments

        Issue Links

          Activity

            danielbeck Daniel Beck added a comment -

            May be a duplicate of JENKINS-32340, but not sure.

            danielbeck Daniel Beck added a comment - May be a duplicate of JENKINS-32340 , but not sure.
            danielbeck Daniel Beck added a comment -

            Does this issue still occur in Jenkins 2.1+ with the fix for JENKINS-32340?

            danielbeck Daniel Beck added a comment - Does this issue still occur in Jenkins 2.1+ with the fix for JENKINS-32340 ?

            I still have this problem with Jenkins 2.7.4 LTS. For example the Windows Slaves Plugin cannot be disabled, it claims that the jQuery plugin and other plugins depend on it. See attached screenshot.

            arend_von_reinersdorff Arend v. Reinersdorff added a comment - I still have this problem with Jenkins 2.7.4 LTS. For example the Windows Slaves Plugin cannot be disabled, it claims that the jQuery plugin and other plugins depend on it. See attached screenshot.
            danielbeck Daniel Beck added a comment -

            For example the Windows Slaves Plugin cannot be disabled, it claims that the jQuery plugin and other plugins depend on it.

            Not a bug, just a side effect of outdated core dependencies predating the release when Windows Slaves was detached from core and made into a plugin. Jenkins needs to assume an implied dependency exists.

            danielbeck Daniel Beck added a comment - For example the Windows Slaves Plugin cannot be disabled, it claims that the jQuery plugin and other plugins depend on it. Not a bug, just a side effect of outdated core dependencies predating the release when Windows Slaves was detached from core and made into a plugin. Jenkins needs to assume an implied dependency exists.

            danielbeck I'm sorry, I wasn't aware of that. Thanks for pointing it out

            arend_von_reinersdorff Arend v. Reinersdorff added a comment - danielbeck I'm sorry, I wasn't aware of that. Thanks for pointing it out
            danielbeck Daniel Beck added a comment -

            Assuming this was fixed (except for the more specialized JENKINS-33843)  in 2.1.

            danielbeck Daniel Beck added a comment - Assuming this was fixed (except for the more specialized JENKINS-33843 )  in 2.1.

            People

              Unassigned Unassigned
              kwisatz David Raison
              Votes:
              2 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: