Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-32703

Unable to use LDAP accounts as remote user to connect slaves using EC2 plugin

    XMLWordPrintable

Details

    • Bug
    • Status: Open (View Workflow)
    • Major
    • Resolution: Unresolved
    • ec2-plugin
    • None
    • EC2 1.29

    Description

      Hi,

      Using EC2 plugin we are launching linux instances .While configuring we are giving remote user as "root",then instances able to connect .But if we use LDAP accounts which have access are not able to connect instances after launching ,Authentication is getting failed.Could you please help to check this issue[attached log]

      Attachments

        1. auth.log
          3 kB
        2. jenkins_1.31.log
          7 kB
        3. jenkins._auth.log
          5 kB

        Activity

          svmkphani Murali Phani added a comment -

          Not spot instances.Normal instances in our org cloud

          svmkphani Murali Phani added a comment - Not spot instances.Normal instances in our org cloud

          Having problems when launching Spot Instances as the slave.jar does not get any credentials passed through.

          Normal EC2 instances works perfectly.

          lifeofguenter Günter Grodotzki added a comment - Having problems when launching Spot Instances as the slave.jar does not get any credentials passed through. Normal EC2 instances works perfectly.
          svmkphani Murali Phani added a comment - - edited

          Able to launch slave .But authentication issue remain there.Please find attached log jenkins._auth.log

          svmkphani Murali Phani added a comment - - edited Able to launch slave .But authentication issue remain there.Please find attached log jenkins._auth.log
          francisu Francis Upton added a comment - - edited Sorry, I meant use this hpi: https://jenkins.ci.cloudbees.com/job/plugins/job/ec2-plugin/382/org.jenkins-ci.plugins$ec2/artifact/org.jenkins-ci.plugins/ec2/1.32-SNAPSHOT/ec2-1.32-SNAPSHOT.hpi
          svmkphani Murali Phani added a comment -

          Using 1.31.Not able to launch slaves at all.Please find attached log

          svmkphani Murali Phani added a comment - Using 1.31.Not able to launch slaves at all.Please find attached log
          francisu Francis Upton added a comment -

          Can you try this with 1.31 as the logging is better and there have been fixes in the authentication stuff?

          francisu Francis Upton added a comment - Can you try this with 1.31 as the logging is better and there have been fixes in the authentication stuff?

          People

            francisu Francis Upton
            svmkphani Murali Phani
            Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated: