Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-32745

Plugin don't work using a variable in the repository url

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Not A Defect
    • Component/s: gitlab-hook-plugin
    • Labels:
      None
    • Environment:
      Jenkins ver. 1.646
      Gitlab hook plugin 1.4.1.1
    • Similar Issues:

      Description

      Add in configuration a environment called:
      GIT_REPO with value github.com
      At a job configure the git repository like this:
      git@${GIT_REPO}:/jenkinsci/gitlab-hook-plugin.git

      Using normal git polling system works but not the gitlab hook plugin.
      At the log it shows there are not matching projects

        Attachments

          Activity

          javiplx Javier Palacios added a comment -

          I don´t really see the utility of using a variable in repository name, except for user triggered parametrized builds, but this plugin will never work in such a situation.
          What the plugin does at the very begining is to extract the repository url from the incoming gitlab payload, and search in jenkins projects configured with that url, and although theoretically it could handle variables in the git repo, the problem is that there is no way to assign a value to GIT_REPO.


            People

            Assignee:
            javiplx Javier Palacios
            Reporter:
            sermelo Sergio Merino
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: