Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-33148

jelly file throws the exception

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Major
    • Resolution: Fixed
    • email-ext-plugin

    Description

      I have installed the jenkins and the email ext plugin.

      When I test with the attached jelly file, I got this error.

      ("JellyException: Could not parse Jelly script : null")+*.So i have taken the sample jelly file from Github even that generate the same exception.Then jenkin errorlog show some exception such as
      WARNING: Failed to load hudson.plugins.emailext.EmailExtStep$DescriptorImpl
      java.lang.InstantiationException: java.lang.NoClassDefFoundError: org/jenkinsci/plugins/workflow/steps/AbstractStepDescriptorImpl
      at net.java.sezpoz.IndexItem.element(IndexItem.java:146)
      at hudson.ExtensionFinder$Sezpoz._find(ExtensionFinder.java:623)
      at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:612)
      at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:388)
      at hudson.ExtensionList.load(ExtensionList.java:349)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:287)
      at hudson.ExtensionList.iterator(ExtensionList.java:156)
      at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:381)
      at hudson.ExtensionList.load(ExtensionList.java:349)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:287)
      at hudson.ExtensionList.get(ExtensionList.java:171)
      at hudson.PluginManager$PluginUpdateMonitor.getInstance(PluginManager.java:1326)
      at hudson.maven.PluginImpl.init(PluginImpl.java:58)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:106)
      at hudson.init.TaskMethodFinder$TaskImpl.run(TaskMethodFinder.java:176)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
      at jenkins.model.Jenkins$8.runTask(Jenkins.java:924)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at java.lang.Thread.run(Unknown Source)
      Caused by: java.lang.NoClassDefFoundError: org/jenkinsci/plugins/workflow/steps/AbstractStepDescriptorImpl
      at java.lang.ClassLoader.defineClass1(Native Method)
      at java.lang.ClassLoader.defineClass(Unknown Source)
      at jenkins.util.AntClassLoader.defineClassFromData(AntClassLoader.java:1139)
      at hudson.ClassicPluginStrategy$AntClassLoader2.defineClassFromData(ClassicPluginStrategy.java:801)
      at jenkins.util.AntClassLoader.getClassFromStream(AntClassLoader.java:1310)
      at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1366)
      at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1326)
      at sun.reflect.GeneratedMethodAccessor5.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at jenkins.ClassLoaderReflectionToolkit.invoke(ClassLoaderReflectionToolkit.java:44)
      at jenkins.ClassLoaderReflectionToolkit._findClass(ClassLoaderReflectionToolkit.java:86)
      at hudson.PluginManager$UberClassLoader.findClass(PluginManager.java:1188)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      at net.java.sezpoz.IndexItem.element(IndexItem.java:134)
      ... 25 more
      Caused by: java.lang.ClassNotFoundException: org.jenkinsci.plugins.workflow.steps.AbstractStepDescriptorImpl
      at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1376)
      at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1326)
      at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1079)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      ... 41 more

      Attachments

        Issue Links

          Activity

            slide_o_mix Alex Earl added a comment -

            Please upgrade to 2.41.3, this is a known issue that was fixed

            slide_o_mix Alex Earl added a comment - Please upgrade to 2.41.3, this is a known issue that was fixed

            People

              slide_o_mix Alex Earl
              gautham Gautham Rathina kumar
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: