Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-33626

Cannot merge into a working copy with a switched subtree

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: svnmerge-plugin
    • Labels:
      None
    • Environment:
      Jenkins (1.653), Subversion Plug-in 2.5.7, svnmerge plugin 2.6, config for svn set to 1.7
    • Similar Issues:

      Description

      When trying to merge a feature branch into trunk we keep getting this error:

      ERROR: Step ‘Integrate to upstream upon successful build’ aborted due to exception:
      hudson.util.IOException2: Failed to merge
      at jenkins.plugins.svnmerge.FeatureBranchProperty$2.invoke(FeatureBranchProperty.java:412)
      at jenkins.plugins.svnmerge.FeatureBranchProperty$2.invoke(FeatureBranchProperty.java:292)
      at hudson.FilePath.act(FilePath.java:990)
      at hudson.FilePath.act(FilePath.java:968)
      at jenkins.plugins.svnmerge.FeatureBranchProperty.integrate(FeatureBranchProperty.java:292)
      at jenkins.plugins.svnmerge.IntegrateAction.perform(IntegrateAction.java:175)
      at jenkins.plugins.svnmerge.IntegrateAction.perform(IntegrateAction.java:165)
      at jenkins.plugins.svnmerge.IntegrationPublisher.perform(IntegrationPublisher.java:51)
      at hudson.tasks.BuildStepMonitor$2.perform(BuildStepMonitor.java:32)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:782)
      at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:723)
      at hudson.model.Build$BuildExecution.post2(Build.java:185)
      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:668)
      at hudson.model.Run.execute(Run.java:1763)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:98)
      at hudson.model.Executor.run(Executor.java:410)
      Caused by: org.tmatesoft.svn.core.SVNException: svn: E195016: Cannot merge into a working copy with a switched subtree
      at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:64)
      at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)
      at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgMergeDriver.ensureWcIsSuitableForMerge(SvnNgMergeDriver.java:236)
      at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgMergeReintegrate.merge(SvnNgMergeReintegrate.java:107)
      at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgMergeReintegrate.run(SvnNgMergeReintegrate.java:65)
      at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgMergeReintegrate.run(SvnNgMergeReintegrate.java:45)
      at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgOperationRunner.run(SvnNgOperationRunner.java:20)
      at org.tmatesoft.svn.core.internal.wc2.SvnOperationRunner.run(SvnOperationRunner.java:21)
      at org.tmatesoft.svn.core.wc2.SvnOperationFactory.run(SvnOperationFactory.java:1235)
      at org.tmatesoft.svn.core.wc2.SvnOperation.run(SvnOperation.java:294)
      at org.tmatesoft.svn.core.wc.SVNDiffClient.doMergeReIntegrate(SVNDiffClient.java:2632)
      at jenkins.plugins.svnmerge.FeatureBranchProperty$2.invoke(FeatureBranchProperty.java:346)
      ... 16 more

      The project is up to date for rebaseing:

      Rebasing is in progress

      Updating workspace to the latest revision
      At revision 29259

      Merging change from the upstream https://****/svn/marketforce1_lf1/trunk at rev.29258
      Committing changes
      No changes since the last rebase. This rebase was a no-op.
      Completed

        Attachments

          Activity

          fillmorejd Jeff Fillmore added a comment -

          Updated to svn 1.8 and it is now working


            People

            Assignee:
            kohsuke Kohsuke Kawaguchi
            Reporter:
            fillmorejd Jeff Fillmore
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: