Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-33686

Build triggered via "Build other projects (manual step)" has no connection to upstream job

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Duplicate
    • Component/s: build-pipeline-plugin
    • Labels:
      None
    • Environment:
      Jenkins Version: 1.653
      Build Pipeline Plugin Version: 1.5.1
    • Similar Issues:

      Description

      Setup:

      Simple Build Pipeline "Build A -> Build B"

      Build A:
      Build: Shell execution 'echo "Hello"'
      Post Build Action:
      Build other projects (manual step): "Build B"

      Build B:
      Build: Shell execution 'echo "World"'

      Problem / Steps to reproduce

      1. Pressing "Run" in Build Pipeline View triggers "Build A"
      2. Build A goes green >
      3. Trigger "Build B" in Build Pipeline View
      4. Build B runs and and finishes with succes
      5. Build B does not get green in the Pipeline
      6. Build B has no connection to the upstream job

      Additional information

      • The problem did not occur in Jenkins versions 1.642.2, 1.642.3 and also not in 1.652
      • In the working versions we can see the following env variables:
        BUILD_CAUSE	MANUALTRIGGER,UPSTREAMTRIGGER
        BUILD_CAUSE_MANUALTRIGGER	true
        BUILD_CAUSE_UPSTREAMTRIGGER	true
        
      • In the new version the env variables only state the following:
        BUILD_CAUSE	MANUALTRIGGER
        BUILD_CAUSE_MANUALTRIGGER	true
        
      • When Build B tries to copy an artifact from upstream build, it fails
      • The information "Started by upstream project "Build A" build number x" is missing in the console output of Build B

        Attachments

          Issue Links

            Activity

            dalvizu Dan Alvizu added a comment -

            Thanks for the detailed steps, Angelo Veltens - this is a duplicate of JENKINS-33591, so it will be tracked there.


              People

              Assignee:
              dalvizu Dan Alvizu
              Reporter:
              aveltens Angelo Veltens
              Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: