Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-33855

HTTP/S Proxy Settings Not Taking Effect

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      The Jenkins instance is having the proxy settings as per the Jenkins docs (Manage Jenkins > Manage Plugins > Advanced).
      The test of the Mattermost url at this page works fine in the Jenkins instance. At the same time, the test of the mattermost channel update in the Job configuration fails for reaching the Mattermost servers via proxy.

        Attachments

          Activity

          Hide
          jovandeginste Jo Vandeginste added a comment -

          I have built a version with more logging around the proxy'ing, it seems to work as expected.

          I tried:

          • no proxy configuration at all
          • simple proxy configuration (no exception)
          • proxy configuration with exception for mattermost domain

          All these configurations seem to work as expected, both for clicking the "test" buttons as for real publish-events.

          I can share the version with more logging, so you can try this yourself?

          Show
          jovandeginste Jo Vandeginste added a comment - I have built a version with more logging around the proxy'ing, it seems to work as expected. I tried: no proxy configuration at all simple proxy configuration (no exception) proxy configuration with exception for mattermost domain All these configurations seem to work as expected, both for clicking the "test" buttons as for real publish-events. I can share the version with more logging, so you can try this yourself?
          Hide
          jovandeginste Jo Vandeginste added a comment -

          Just to be sure, are you using 1.5.0? The proxy-implementation has been redone in 1.5.0, so this may be very relevant...

          Show
          jovandeginste Jo Vandeginste added a comment - Just to be sure, are you using 1.5.0? The proxy-implementation has been redone in 1.5.0, so this may be very relevant...
          Hide
          vrenjith Renjith Pillai added a comment -

          Jo, that was an important hint. I just upgraded to 1.5.0 and it is working perfectly. Thank you so much for spending time on checking this.

          Show
          vrenjith Renjith Pillai added a comment - Jo, that was an important hint. I just upgraded to 1.5.0 and it is working perfectly. Thank you so much for spending time on checking this.
          Hide
          jovandeginste Jo Vandeginste added a comment -

          Great, glad it's solved! I'm not really a Java or Jenkins-plugin-specialist so this is more of a side project and thus I'm happy this was an easy fix . I improved a bit on the logging side in general in 1.5.1 ...

          Show
          jovandeginste Jo Vandeginste added a comment - Great, glad it's solved! I'm not really a Java or Jenkins-plugin-specialist so this is more of a side project and thus I'm happy this was an easy fix . I improved a bit on the logging side in general in 1.5.1 ...

            People

            Assignee:
            jovandeginste Jo Vandeginste
            Reporter:
            vrenjith Renjith Pillai
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: