Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3407

Failed to initialize Hudson

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: Sun, OS: Solaris
    • Similar Issues:

      Description

      Starting with release 1.293 Hudson fails to start:

      SEVERE: Failed to initialize Hudson
      java.lang.NoSuchMethodError: hudson.model.PeriodicWork.<init>(Ljava/lang/String;)V
      at hudson.plugins.disk_usage.DiskUsageThread.<init>(DiskUsageThread.java:26)
      at hudson.plugins.disk_usage.DiskUsagePlugin.<init>(DiskUsagePlugin.java:30)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      at
      sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
      at
      sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
      at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
      at java.lang.Class.newInstance0(Class.java:350)
      at java.lang.Class.newInstance(Class.java:303)
      at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:190)
      at hudson.PluginManager.<init>(PluginManager.java:141)
      at hudson.model.Hudson.<init>(Hudson.java:513)
      at hudson.WebAppMain$2.run(WebAppMain.java:191)
      Exception in thread "hudson initialization thread" java.lang.NoSuchMethodError:
      hudson.model.PeriodicWork.<init>(Ljava/lang/String;)V
      at hudson.plugins.disk_usage.DiskUsageThread.<init>(DiskUsageThread.java:26)
      at hudson.plugins.disk_usage.DiskUsagePlugin.<init>(DiskUsagePlugin.java:30)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      at
      sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
      at
      sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
      at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
      at java.lang.Class.newInstance0(Class.java:350)
      at java.lang.Class.newInstance(Class.java:303)
      at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:190)
      at hudson.PluginManager.<init>(PluginManager.java:141)
      at hudson.model.Hudson.<init>(Hudson.java:513)
      at hudson.WebAppMain$2.run(WebAppMain.java:191)

      -----------------

      this is the same for
      java -jar hudson as well for tomcat 5.5.27

      > uname -a
      SunOS sun1 5.10 Generic_118833-36 sun4v sparc SUNW,Sun-Fire-T1000

      > java -version
      java version "1.5.0_07" Java(TM) 2 Runtime Environment, Standard Edition (build
      1.5.0_07-b03)
      Java HotSpot(TM) Server VM (build 1.5.0_07-b03, mixed mode)

        Attachments

          Issue Links

            Activity

            mindless Alan Harder added a comment -

            update to disk-usage version 0.8

                • This issue has been marked as a duplicate of 3340 ***

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              alexpen alexpen
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: