Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-34175

It does not seem possible to execute an orchestrator workflow that requires no user input.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Labels:
      None
    • Environment:
      Jenkins Master (CentOS) 1.609.1 LTS
      vmware-realize-orchestrator-plugin version 2.0
      Java version: JDK1.8
      Orchestrator vApp version 7.0.1
    • Similar Issues:

      Description

      It does not seem possible to execute an orchestrator workflow that requires no user input. (Example = all orchestrator workflow inputs are set as attributes). When the plugin has nothing to pass, the jenkins console reports there has been a "HTTP/1.1 400 Bad Request"

      Jenkins Console Output:
      07:35:15 Started by user anonymous
      07:35:15 [EnvInject] - Loading node environment variables.
      07:35:15 Building remotely on anonymous in workspace F:\jenkins\workspace\anonymous_orchestrator_jenkins_send_notification_null
      07:35:16 Starting Orchestrator workflow execution : a18ceeea-e29e-4d04-8f73-4733e63f76d4
      07:35:19 FATAL: Server responded with status code HTTP/1.1 400 Bad Request
      07:35:19 java.io.IOException: Server responded with status code HTTP/1.1 400 Bad Request
      07:35:19 at com.vmware.vro.jenkins.plugin.OrchestratorCallable.call(OrchestratorCallable.java:66)
      07:35:19 at com.vmware.vro.jenkins.plugin.OrchestratorCallable.call(OrchestratorCallable.java:17)
      07:35:19 at hudson.remoting.UserRequest.perform(UserRequest.java:121)
      07:35:19 at hudson.remoting.UserRequest.perform(UserRequest.java:49)
      07:35:19 at hudson.remoting.Request$2.run(Request.java:325)
      07:35:19 at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      07:35:19 at java.util.concurrent.FutureTask.run(Unknown Source)
      07:35:19 at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      07:35:19 at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      07:35:19 at hudson.remoting.Engine$1$1.run(Engine.java:69)
      07:35:19 at java.lang.Thread.run(Unknown Source)
      07:35:19 at ......remote call to anonymous(Native Method)
      07:35:19 at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1360)
      07:35:19 at hudson.remoting.UserResponse.retrieve(UserRequest.java:221)
      07:35:19 at hudson.remoting.Channel.call(Channel.java:753)
      07:35:19 at com.vmware.vro.jenkins.plugin.OrchestratorBuilder.perform(OrchestratorBuilder.java:113)
      07:35:19 at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      07:35:19 at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:761)
      07:35:19 at hudson.model.Build$BuildExecution.build(Build.java:203)
      07:35:19 at hudson.model.Build$BuildExecution.doRun(Build.java:160)
      07:35:19 at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:536)
      07:35:19 at hudson.model.Run.execute(Run.java:1741)
      07:35:19 at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      07:35:19 at hudson.model.ResourceController.execute(ResourceController.java:98)
      07:35:19 at hudson.model.Executor.run(Executor.java:374)
      07:35:19 Caused by: java.io.IOException: Server responded with status code HTTP/1.1 400 Bad Request
      07:35:19 at com.vmware.vro.jenkins.plugin.util.RestClient.httpPostForLocationHeader(RestClient.java:105)
      07:35:19 at com.vmware.vro.jenkins.plugin.OrchestratorClient.executeWorkflow(OrchestratorClient.java:135)
      07:35:19 at com.vmware.vro.jenkins.plugin.OrchestratorCallable.call(OrchestratorCallable.java:31)
      07:35:19 at com.vmware.vro.jenkins.plugin.OrchestratorCallable.call(OrchestratorCallable.java:17)
      07:35:19 at hudson.remoting.UserRequest.perform(UserRequest.java:121)
      07:35:19 at hudson.remoting.UserRequest.perform(UserRequest.java:49)
      07:35:19 at hudson.remoting.Request$2.run(Request.java:325)
      07:35:19 at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      07:35:19 at java.util.concurrent.FutureTask.run(Unknown Source)
      07:35:19 at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      07:35:19 at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      07:35:19 at hudson.remoting.Engine$1$1.run(Engine.java:69)
      07:35:19 at java.lang.Thread.run(Unknown Source)
      07:35:19 [BFA] Scanning build for known causes...
      07:35:19 [BFA] No failure causes found
      07:35:19 [BFA] Done. 0s
      07:35:19 Started calculate disk usage of build
      07:35:19 Finished Calculation of disk usage of build in 0 seconds
      07:35:19 Started calculate disk usage of workspace
      07:35:19 Finished Calculation of disk usage of workspace in 0 seconds
      07:35:19 Finished: FAILURE

      If the orchestrator workflow is run manually in workflow designer, the workflow runs successfully.

        Attachments

          Activity

          agovindaraju Agila Govindaraju added a comment -

          Will take a look at it and post the updates.

          agovindaraju Agila Govindaraju added a comment -

          This I have fixed. Will release it.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Agila Govindaraju
          Path:
          src/main/java/com/vmware/vro/jenkins/plugin/OrchestratorClient.java
          http://jenkins-ci.org/commit/vmware-vrealize-orchestrator-plugin/0b067fb4a4410c800d6bfb4a961c41efa21c7fef
          Log:
          Fixed Issue JENKINS-34175

          vRO needs empty payload for no input workflow. Added that now.

          agovindaraju Agila Govindaraju added a comment -

          Released version 3.0 has this fix.


            People

            Assignee:
            agovindaraju Agila Govindaraju
            Reporter:
            kraems Bob Kraemer
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: