Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-34178

There *may* be a problem with the vm@VC:VirtualMachine parameter name.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Labels:
      None
    • Environment:
      Jenkins Master (CentOS) 1.609.1 LTS
      vmware-realize-orchestrator-plugin version 2.0
      Java version: JDK1.8
      Orchestrator vApp version 7.0.1
    • Similar Issues:

      Description

      There may be a problem with the vm@VC:VirtualMachine parameter name. As an example, I have two jenkins jobs, each job passing a single parameter to it's linked orchestrator workflow (Copy file from vCO to guest). The only difference between the two scenarios is that in one case (the failure) Jenkins uses the vm@VC:VirtualMachine parameter name as the sole input to the orchestrator workflow. In the case that succeeds, the VM variable is set in the orchestrator workflow as an attribute, and the jenkins job passes another variable, instead (the VM password) as the sole parameter passed from jenkins to orchestrator. Other than the change to the single input type passed by jenkins (vm@VC:VirtualMachine parameter versus VM Password) all other aspects appear identical. When I manually run the orchestrator workflow from the failed scenario in workflow designer, the workflow runs fine after specifying the VC:VirtualMachine input parameter.

      Orchestrator Appliance log stream:
      2016-04-12 07:42:38.857-0400 [WorkflowExecutorPool-Thread-329] INFO

      {anonymous:copy anonymous to anonymous vm:dfd361ec-f0d0-4ff5-b105-aade124c9aee:token=8a6d44ad53c834cd01540a47cb120cd3}

      [WorkflowHandler] Starting workflow 'copy anonymous to anonymous vm' (8a6d44ad53c834cd01540a47cb120cd3)...

      2016-04-12 07:42:38.867-0400 [WorkflowExecutorPool-Thread-329] INFO

      {anonymous:copy anonymous to anonymous vm:dfd361ec-f0d0-4ff5-b105-aade124c9aee:token=8a6d44ad53c834cd01540a47cb120cd3}

      [VimPluginFactory] VimPluginFactory() finished in 2 ms; tokenPrincipal: anonymous; sessionId: dbcfd2bb-dec9-4249-b0ae-c06e78b02608

      2016-04-12 07:42:38.868-0400 [WorkflowExecutorPool-Thread-329] WARN

      {anonymous:copy anonymous to anonymous vm:dfd361ec-f0d0-4ff5-b105-aade124c9aee:token=8a6d44ad53c834cd01540a47cb120cd3}

      [VimPluginFactory] find() --> sdkType 'VirtualMachine', id 'anonymous', VimHost 'anonymous' does not exist

      2016-04-12 07:42:38.875-0400 [WorkflowExecutorPool-Thread-329] WARN

      {anonymous:copy anonymous to anonymous vm:dfd361ec-f0d0-4ff5-b105-aade124c9aee:token=8a6d44ad53c834cd01540a47cb120cd3}

      [VimPluginFactory] find() --> sdkType 'VirtualMachine', id 'anonymous', VimHost 'anonymous' does not exist

      2016-04-12 07:42:38.933-0400 [WorkflowExecutorPool-Thread-329] ERROR

      {anonymous:copy anonymous to anonymous vm:dfd361ec-f0d0-4ff5-b105-aade124c9aee:token=8a6d44ad53c834cd01540a47cb120cd3}

      [SCRIPTING_LOG] [copy anonymous to anonymous vm (4/12/16 07:42:37)] Error in (Workflow:copy anonymous to anonymous vm / Scriptable task (item1)#2) TypeError: Cannot read property "guestOperationsManager" from undefined

      2016-04-12 07:42:38.936-0400 [WorkflowExecutorPool-Thread-329] WARN

      {anonymous:copy anonymous to anonymous vm:dfd361ec-f0d0-4ff5-b105-aade124c9aee:token=8a6d44ad53c834cd01540a47cb120cd3}

      [WorkflowItemTaskRunner] Script execution error on workflow : copy anonymous to anonymous vm / 'Scriptable task'(item1) : TypeError: Cannot read property "guestOperationsManager" from undefined (Workflow:copy anonymous to anonymous vm / Scriptable task (item1)#2)

      2016-04-12 07:42:38.943-0400 [WorkflowExecutorPool-Thread-329] ERROR

      {anonymous:copy anonymous to anonymous vm:dfd361ec-f0d0-4ff5-b105-aade124c9aee:token=8a6d44ad53c834cd01540a47cb120cd3}

      [SCRIPTING_LOG] Workfow execution stack:
      ***
      item: 'copy anonymous to anonymous vm/item1', state: 'failed', business state: 'null', exception: 'TypeError: Cannot read property "guestOperationsManager" from undefined (Workflow:copy anonymous to anonymous vm / Scriptable task (item1)#2)'
      workflow: 'copy anonymous to anonymous vm' (dfd361ec-f0d0-4ff5-b105-aade124c9aee)

      'attribute': name=attVMUsername type=string value=anonymous
      'attribute': name=attGuestFilePath type=string value=C:\test_lab_tools.exe
      'attribute': name=attVCOPath type=string value=/storage/autodeploy/anonymous241_tools.exe
      'attribute': name=attOverwrite type=boolean value=true
      'attribute': name=attVMPassword type=SecureString value=_NULL_
      'input': name=vm type=VC:VirtualMachine value=dunes://service.dunes.ch/CustomSDKObject?id='anonymous'&dunesName='VC:VirtualMachine'
      'output': name=result type=boolean value=null
          • End of execution stack.

      Jenkins Console Output:
      07:42:35 Started by user anonymous
      07:42:35 [EnvInject] - Loading node environment variables.
      07:42:35 Building remotely on anonymous in workspace F:\jenkins\workspace\anonymous_orchestrator_copy-anonymous-to-anonymous_vm
      07:42:36 Starting Orchestrator workflow execution : dfd361ec-f0d0-4ff5-b105-aade124c9aee
      07:42:48 FATAL: Workflow execution failed.
      07:42:48 java.io.IOException: Workflow execution failed.
      07:42:48 at com.vmware.vro.jenkins.plugin.OrchestratorCallable.call(OrchestratorCallable.java:66)
      07:42:48 at com.vmware.vro.jenkins.plugin.OrchestratorCallable.call(OrchestratorCallable.java:17)
      07:42:48 at hudson.remoting.UserRequest.perform(UserRequest.java:121)
      07:42:48 at hudson.remoting.UserRequest.perform(UserRequest.java:49)
      07:42:48 at hudson.remoting.Request$2.run(Request.java:325)
      07:42:48 at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      07:42:48 at java.util.concurrent.FutureTask.run(Unknown Source)
      07:42:48 at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      07:42:48 at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      07:42:48 at hudson.remoting.Engine$1$1.run(Engine.java:69)
      07:42:48 at java.lang.Thread.run(Unknown Source)
      07:42:48 at ......remote call to anonymous(Native Method)
      07:42:48 at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1360)
      07:42:48 at hudson.remoting.UserResponse.retrieve(UserRequest.java:221)
      07:42:48 at hudson.remoting.Channel.call(Channel.java:753)
      07:42:48 at com.vmware.vro.jenkins.plugin.OrchestratorBuilder.perform(OrchestratorBuilder.java:113)
      07:42:48 at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      07:42:48 at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:761)
      07:42:48 at hudson.model.Build$BuildExecution.build(Build.java:203)
      07:42:48 at hudson.model.Build$BuildExecution.doRun(Build.java:160)
      07:42:48 at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:536)
      07:42:48 at hudson.model.Run.execute(Run.java:1741)
      07:42:48 at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      07:42:48 at hudson.model.ResourceController.execute(ResourceController.java:98)
      07:42:48 at hudson.model.Executor.run(Executor.java:374)
      07:42:48 Caused by: java.io.IOException: Workflow execution failed.
      07:42:48 at com.vmware.vro.jenkins.plugin.OrchestratorCallable.call(OrchestratorCallable.java:52)
      07:42:48 at com.vmware.vro.jenkins.plugin.OrchestratorCallable.call(OrchestratorCallable.java:17)
      07:42:48 at hudson.remoting.UserRequest.perform(UserRequest.java:121)
      07:42:48 at hudson.remoting.UserRequest.perform(UserRequest.java:49)
      07:42:48 at hudson.remoting.Request$2.run(Request.java:325)
      07:42:48 at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      07:42:48 at java.util.concurrent.FutureTask.run(Unknown Source)
      07:42:48 at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      07:42:48 at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      07:42:48 at hudson.remoting.Engine$1$1.run(Engine.java:69)
      07:42:48 at java.lang.Thread.run(Unknown Source)
      07:42:48 [BFA] Scanning build for known causes...
      07:42:48 [BFA] No failure causes found
      07:42:48 [BFA] Done. 0s
      07:42:48 Started calculate disk usage of build
      07:42:48 Finished Calculation of disk usage of build in 0 seconds
      07:42:48 Started calculate disk usage of workspace
      07:42:48 Finished Calculation of disk usage of workspace in 0 seconds
      07:42:48 Finished: FAILURE

      Despite the Orchestrator Appliance log stream identifying "'VirtualMachine', id 'anonymous', VimHost 'anonymous' does not exist", clearly, that host does exist, as when I manually run the orchestrator workflow from the failed scenario in workflow designer, the workflow runs fine after specifying the VC:VirtualMachine input parameter.

        Attachments

          Activity

          agovindaraju Agila Govindaraju added a comment -

          Attached an image for your reference.

          kraems Bob Kraemer added a comment -

          I am happy to try all the options you ask ~ I just wish a more positive result would come back.
          I've tried the latest suggestion - and I see no change. I'll attached screen captures of the id listed in the inventory, the jenkins job configuration showing the value of the vm@VC:VirtualMachine parameter name, as well as sanitized output from the orchestrator appliance log, jenkins console, and orchestrator logs tab:

          Sanitized orchestrator appliance log:

          2016-05-16 07:46:03.981-0400 [http-nio-0.0.0.0-8281-exec-18] INFO {} [Execution] Executing workflow 'copy get_build.bat to myVM vm'

          2016-05-16 07:46:03.991-0400 org.springframework.jms.listener.DefaultMessageListenerContainer#0-3 INFO {} [Execution] Invoking workflow handler.8a6d44ad54529b650154b963284e5413

          2016-05-16 07:46:04.520-0400 [http-nio-0.0.0.0-8281-exec-14] WARN {} [VimPluginFactory] find() --> sdkType 'VirtualMachine', id 'vm-244555', VimHost 'vm-244555' does not exist

          2016-05-16 07:46:04.607-0400 [http-nio-0.0.0.0-8281-exec-13] WARN {} [VimPluginFactory] find() --> sdkType 'VirtualMachine', id 'vm-244555', VimHost 'vm-244555' does not exist

          2016-05-16 07:46:05.007-0400 [WorkflowExecutorPool-Thread-337] INFO

          {anonymous@mydomain.com:copy get_build.bat to myVM vm:dfd361ec-f0d0-4ff5-b105-aade124c9aee:token=8a6d44ad54529b650154b963284e5413}

          [WorkflowHandler] Starting workflow 'copy get_build.bat to myVM vm' (8a6d44ad54529b650154b963284e5413)...

          2016-05-16 07:46:05.013-0400 [WorkflowExecutorPool-Thread-337] INFO

          {anonymous@mydomain.com:copy get_build.bat to myVM vm:dfd361ec-f0d0-4ff5-b105-aade124c9aee:token=8a6d44ad54529b650154b963284e5413}

          [VimPluginFactory] VimPluginFactory() finished in 2 ms; tokenPrincipal: anonymous@mydomain.com; sessionId: f7fe8a60-0ffd-408c-9457-13ff6405757a

          2016-05-16 07:46:05.014-0400 [WorkflowExecutorPool-Thread-337] WARN

          {anonymous@mydomain.com:copy get_build.bat to myVM vm:dfd361ec-f0d0-4ff5-b105-aade124c9aee:token=8a6d44ad54529b650154b963284e5413}

          [VimPluginFactory] find() --> sdkType 'VirtualMachine', id 'myhost.mydomain.com@vm-244555', VimHost 'myhost.mydomain.com@vm-244555' does not exist

          2016-05-16 07:46:05.021-0400 [WorkflowExecutorPool-Thread-337] WARN

          {anonymous@mydomain.com:copy get_build.bat to myVM vm:dfd361ec-f0d0-4ff5-b105-aade124c9aee:token=8a6d44ad54529b650154b963284e5413}

          [VimPluginFactory] find() --> sdkType 'VirtualMachine', id 'myhost.mydomain.com@vm-244555', VimHost 'myhost.mydomain.com@vm-244555' does not exist

          2016-05-16 07:46:05.023-0400 [WorkflowExecutorPool-Thread-337] ERROR

          {anonymous@mydomain.com:copy get_build.bat to myVM vm:dfd361ec-f0d0-4ff5-b105-aade124c9aee:token=8a6d44ad54529b650154b963284e5413}

          [SCRIPTING_LOG] [copy get_build.bat to myVM vm (5/16/16 07:46:03)] Error in (Workflow:copy get_build.bat to myVM vm / Scriptable task (item1)#2) TypeError: Cannot read property "guestOperationsManager" from undefined

          2016-05-16 07:46:05.033-0400 [WorkflowExecutorPool-Thread-337] WARN

          {anonymous@mydomain.com:copy get_build.bat to myVM vm:dfd361ec-f0d0-4ff5-b105-aade124c9aee:token=8a6d44ad54529b650154b963284e5413}

          [WorkflowItemTaskRunner] Script execution error on workflow : copy get_build.bat to myVM vm / 'Scriptable task'(item1) : TypeError: Cannot read property "guestOperationsManager" from undefined (Workflow:copy get_build.bat to myVM vm / Scriptable task (item1)#2)

          2016-05-16 07:46:05.040-0400 [WorkflowExecutorPool-Thread-337] ERROR

          {anonymous@mydomain.com:copy get_build.bat to myVM vm:dfd361ec-f0d0-4ff5-b105-aade124c9aee:token=8a6d44ad54529b650154b963284e5413}

          [SCRIPTING_LOG] Workfow execution stack:
          ***
          item: 'copy get_build.bat to myVM vm/item1', state: 'failed', business state: 'null', exception: 'TypeError: Cannot read property "guestOperationsManager" from undefined (Workflow:copy get_build.bat to myVM vm / Scriptable task (item1)#2)'
          workflow: 'copy get_build.bat to myVM vm' (dfd361ec-f0d0-4ff5-b105-aade124c9aee)

          'attribute': name=attVMUsername type=string value=mydomain\anonymous
          'attribute': name=attGuestFilePath type=string value=C:\get_build.bat
          'attribute': name=attVCOPath type=string value=/storage/autodeploy/get_build.bat
          'attribute': name=attOverwrite type=boolean value=true
          'attribute': name=attVMPassword type=SecureString value=_NULL_
          'input': name=vm type=VC:VirtualMachine value=dunes://service.dunes.ch/CustomSDKObject?id='myhost.mydomain.com@vm-244555'&dunesName='VC:VirtualMachine'
          'output': name=result type=boolean value=null
              • End of execution stack.

          2016-05-16 07:46:05.044-0400 [WorkflowExecutorPool-Thread-337] INFO

          {anonymous@mydomain.com:copy get_build.bat to myVM vm:dfd361ec-f0d0-4ff5-b105-aade124c9aee:token=8a6d44ad54529b650154b963284e5413}

          [WorkflowHandler] End of workflow 'copy get_build.bat to myVM vm' (8a6d44ad54529b650154b963284e5413), state: failed

          2016-05-16 07:46:07.729-0400 [http-nio-0.0.0.0-8281-exec-12] WARN {} [VimPluginFactory] find() --> sdkType 'VirtualMachine', id 'myhost.mydomain.com@vm-244555', VimHost 'myhost.mydomain.com@vm-244555' does not exist

          2016-05-16 07:46:07.830-0400 [http-nio-0.0.0.0-8281-exec-18] WARN {} [VimPluginFactory] find() --> sdkType 'VirtualMachine', id 'myhost.mydomain.com@vm-244555', VimHost 'myhost.mydomain.com@vm-244555' does not exist

          Sanitized jenkins console output:

          07:46:01 Started by user anonymous
          07:46:02 [EnvInject] - Loading node environment variables.
          07:46:02 Building remotely on myjenkinsslave in workspace F:\jenkins\workspace\myworkflow
          07:46:02 Starting Orchestrator workflow execution : dfd361ec-f0d0-4ff5-b105-aade124c9aee
          07:46:14 FATAL: Workflow execution failed.
          07:46:14 java.io.IOException: Workflow execution failed.
          07:46:14 at com.vmware.vro.jenkins.plugin.OrchestratorCallable.call(OrchestratorCallable.java:66)
          07:46:14 at com.vmware.vro.jenkins.plugin.OrchestratorCallable.call(OrchestratorCallable.java:17)
          07:46:14 at hudson.remoting.UserRequest.perform(UserRequest.java:121)
          07:46:14 at hudson.remoting.UserRequest.perform(UserRequest.java:49)
          07:46:14 at hudson.remoting.Request$2.run(Request.java:325)
          07:46:14 at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
          07:46:14 at java.util.concurrent.FutureTask.run(Unknown Source)
          07:46:14 at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
          07:46:14 at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
          07:46:14 at hudson.remoting.Engine$1$1.run(Engine.java:69)
          07:46:14 at java.lang.Thread.run(Unknown Source)
          07:46:14 at ......remote call to myjenkinsslave(Native Method)
          07:46:14 at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1416)
          07:46:14 at hudson.remoting.UserResponse.retrieve(UserRequest.java:220)
          07:46:14 at hudson.remoting.Channel.call(Channel.java:781)
          07:46:14 at com.vmware.vro.jenkins.plugin.OrchestratorBuilder.perform(OrchestratorBuilder.java:113)
          07:46:14 at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
          07:46:14 at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:782)
          07:46:14 at hudson.model.Build$BuildExecution.build(Build.java:205)
          07:46:14 at hudson.model.Build$BuildExecution.doRun(Build.java:162)
          07:46:14 at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:534)
          07:46:14 at hudson.model.Run.execute(Run.java:1738)
          07:46:14 at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
          07:46:14 at hudson.model.ResourceController.execute(ResourceController.java:98)
          07:46:14 at hudson.model.Executor.run(Executor.java:410)
          07:46:14 Caused by: java.io.IOException: Workflow execution failed.
          07:46:14 at com.vmware.vro.jenkins.plugin.OrchestratorCallable.call(OrchestratorCallable.java:52)
          07:46:14 at com.vmware.vro.jenkins.plugin.OrchestratorCallable.call(OrchestratorCallable.java:17)
          07:46:14 at hudson.remoting.UserRequest.perform(UserRequest.java:121)
          07:46:14 at hudson.remoting.UserRequest.perform(UserRequest.java:49)
          07:46:14 at hudson.remoting.Request$2.run(Request.java:325)
          07:46:14 at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
          07:46:14 at java.util.concurrent.FutureTask.run(Unknown Source)
          07:46:14 at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
          07:46:14 at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
          07:46:14 at hudson.remoting.Engine$1$1.run(Engine.java:69)
          07:46:14 at java.lang.Thread.run(Unknown Source)
          07:46:14 [BFA] Scanning build for known causes...
          07:46:14 [BFA] No failure causes found
          07:46:14 [BFA] Done. 0s
          07:46:14 Started calculate disk usage of build
          07:46:14 Finished Calculation of disk usage of build in 0 seconds
          07:46:14 Started calculate disk usage of workspace
          07:46:14 Finished Calculation of disk usage of workspace in 0 seconds
          07:46:14 Finished: FAILURE

          Sanitized orchestrator logs tab:

          [2016-05-16 07:46:05.023] [E] Error in (Workflow:copy get_build.bat to some-virtual-machine vm / Scriptable task (item1)#2) TypeError: Cannot read property "guestOperationsManager" from undefined
          [2016-05-16 07:46:05.040] [E] Workfow execution stack:
          ***
          item: 'copy get_build.bat to some-virtual-machine vm/item1', state: 'failed', business state: 'null', exception: 'TypeError: Cannot read property "guestOperationsManager" from undefined (Workflow:copy get_build.bat to some-virtual-machine vm / Scriptable task (item1)#2)'
          workflow: 'copy get_build.bat to some-virtual-machine vm' (dfd361ec-f0d0-4ff5-b105-aade124c9aee)

          'attribute': name=attVMUsername type=string value=mydomain\anonymous
          'attribute': name=attGuestFilePath type=string value=C:\get_build.bat
          'attribute': name=attVCOPath type=string value=/mypath/get_build.bat
          'attribute': name=attOverwrite type=boolean value=true
          'attribute': name=attVMPassword type=SecureString value=_NULL_
          'input': name=vm type=VC:VirtualMachine value=dunes://service.dunes.ch/CustomSDKObject?id='rdvm.mydomain.com@vm-244555'&dunesName='VC:VirtualMachine'
          'output': name=result type=boolean value=null
              • End of execution stack.
          agovindaraju Agila Govindaraju added a comment - - edited

          I still see an @ in your rdvm.mydomain.com@vm-244555 value it should be having / in the value instead of @ for ex: rdvm.mydomain.com/vm-244555

          kraems Bob Kraemer added a comment -

          As it turns out, when you try the notation exactly as you asked - it does indeed work... imagine that. Sorry I missed it the first time.

          I can now confirm that passing a value in the form of myhost.mydomain.com/vm-99999 for the vm@VC:VirtualMachine parameter name (where vm-99999 is the id as displayed in the orchestrator workflow designer inventory tab) does indeed WORK. Issue is closed. Thank you for all of your prompt attention to this.

          agovindaraju Agila Govindaraju added a comment -

          Thanks for trying my suggestions patiently


            People

            Assignee:
            agovindaraju Agila Govindaraju
            Reporter:
            kraems Bob Kraemer
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: