Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-34404

testng-plugin: 502 Bad Gateway when using custom Home directory

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: testng-plugin
    • Labels:
      None
    • Environment:
      Jenkins ver. 1.574
      Testng-Plugin version: 1.10
    • Similar Issues:

      Description

      When using Jenkins with a custom Home directory (ex: /home/jenkins/jenkins-prometheus), it appears that a 502 Bad Gateway error occurs when clicking on the Class Name on a testng test result. Here is an example of the URL that the plugin is trying to navigate to:

      [domain]/jenkins/job/OAM%20-%20Positive%20Testing/8/testngreports/automationFramework/Example_NewUserRegistration

      Changing the URL to the following successfully loads the page for the Class Name:
      [domain]/jenkins-prometheus/job/OAM%20-%20Positive%20Testing/8/testngreports/automationFramework/Example_NewUserRegistration

      It appears that the problem is related to the custom Home directory.

        Attachments

          Activity

          veesonic Mike Jones added a comment -

          I wasn't the person that configured Jenkins on the server, changing the jenkinsURL in the jenkins.model.JenkinsLocationConfiguration.xml file (located in the JENKINS_HOME directory) fixed this issue. Sorry for reporting this.


            People

            Assignee:
            nullin Nalin Makar
            Reporter:
            veesonic Mike Jones
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: