Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-34595

Multibranch Pipeline Project vs SVN branches

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: pipeline
    • Labels:
    • Environment:
      ubuntu lts 14.04, jenkins 2.1
    • Similar Issues:

      Description

      Hi,

      i d'like to use the multibranch Feature with Workflow Plugin Pipelines but it's nearly not possible because of some weird naming for branches.

      Lets say i have specified some SVN URL svn://URL/Project.
      Under this URL there are a trunk Folder (svn://URL/Project/trunk) and some branch Folders (svn://URL/Project/branches/1.0, svn://URL/Project/branches/2.0).

      Jenkins scans the structure and creates 3 Projects:

      • trunk
      • branches/1.0
      • branches/2.0

      The branches here cause some trouble because of the "/" thats handled like "branches%2F1.0".

      Docker & Others tools are throwing errors with this kind of project naming.

      Is it possible to change branches only to have the last part after the "/" as name?

        Attachments

          Issue Links

            Activity

            heinzepreller heinzepreller added a comment -

            sorry just saw this is a duplicate of JENKINS-34564


              People

              Assignee:
              jglick Jesse Glick
              Reporter:
              heinzepreller heinzepreller
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: