Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-34657

Ensure that appropriate plugins are able to be used within Pipeline DSL

    XMLWordPrintable

    Details

    • Epic Name:
      Pipeline Compatibility
    • Similar Issues:

      Description

      For architectural reasons, plugins providing various extensions of interest to builds cannot be made automatically compatible with Pipeline. Typically they require use of some newer APIs, large or small (see the bottom of this document for details). This document captures the ongoing status of plugins known to be compatible or incompatible.

      https://github.com/jenkinsci/pipeline-plugin/blob/master/DEVGUIDE.md

      https://www.youtube.com/watch?v=4zdy7XGx3PA

        Attachments

          Issue Links

            Activity

            There are no comments yet on this issue.

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              hrmpw Patrick Wolf
              Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

                Dates

                Created:
                Updated: