Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-34740

Many XHR requests fail under certain conditions when an underscore is present in the hostname

    XMLWordPrintable

Details

    • Bug
    • Status: Open (View Workflow)
    • Major
    • Resolution: Unresolved
    • core

    Description

      When accessing via a hostname with an underscore, many (or perhaps even all; I haven't enumerated) XHR requests fail – either with a 403 unauthorized (when logged in) or with a 200 OK but blank response (if I log in as anonymous, with anonymous granted Administer privileges).

      Here are a few examples:

      • At /configureSecurity/: XHR calls to /descriptorByName/hudson.security.GlobalMatrixAuthorizationStrategy/checkName?value=%5Busername%5D return either 403 (if logged in) or 200 but blank response (if anonymous w/anonymous granted Administer)
      • At /configureSecurity/: clicking Save or Apply results in an error where an ActiveDirectorySecurityRealm failed to instantiate in org.kohsuke.stapler.Stapler.tryInvoke (Stapler.java:796)
      • At /configure: XHR call to /$stapler/bound/[a GUID]/render returns 404 Not Found
      • At /configure: all other XHR calls executed on load (/checkAdminAddress, checkDefaultSuffix, checkGitUrl, etc.) return 200 OK but have an empty response.

      This issue has been tested and found present in 1.6, 2.2, and 2.3 (I haven't tested any other versions).

      In 2.0+, this results in several major functionality blockers – e.g. the New Item page is blank.

      Attachments

        Activity

          People

            Unassigned Unassigned
            pianoroy Roy Tinker
            Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated: